zidon cannot detect SV-1

I desperately need your help, 'cause I’m going crazy over here: I connected for the 1st time my SV-1 through a USB port to my laptop (using Windows 7) and run Zidon to detect it, but Zidon cannot detect any such device! I tried to connect my voice key to all 3 available USB ports in my laptop but…nothing.
The thing is that another person has already used this SV- with her laptop and E-Prime 2 and it worked fine, so I can’t think of what may go wrong here…
Any help please???

Xidon version 1.x (you’re right, it’s pronounced “Zidon”) is a utility program that was developed for in-house use only. However, over time, some users needed it and we made it available.

SV-1 supports four different communication protocols for transmitting data to the computer. Xidon 1.x will work only with the XID mode. It can convert SV-1’s protocol from XID to the PST SRB protocol that E-Prime requires, but once the protocol is set to PST SRB, Xidon can no longer communicate with SV-1. This is why Xidon cannot detect the device.

We have a new Xidon 2.0 in development that will remove this limitation. Meanwhile, you can use SuperLab 5 by selecting SV-1 as an input device (see Experiment menu > Participant Input) and then clicking on the Auto Detect button SuperLab 5 will convert SV-1’s protocol back to XID.