String Input Box Not Appearing on Mac


I have a rather bizarre problem and this only occurs on the Mac but not the PC. The string input box (at Qn49) will not appear when I run the entire experiment (see attached for Sample Experiment Package) but if I run selected blocks (e.g., from Qn 49 to ‘The End’), it appears.

I have read the other posts on String Input and selected “Only if an event designates a single key response as correct” under “Participant Input” --> “Options”


I would appreciate it if someone could help!

I wasn’t able to open the experiment, it asked me to locate a number of .mp4 files. Can you please send them to me?

Hi acap,

Thanks for providing – your sample helps a lot.

QuickTime movie playback is experiencing some type of graphical conflict with SuperLab string input. (This explains why the problem doesn’t occur on the PC; on the PC, SuperLab uses DirectX instead of QuickTime.)

We will continue to look into this problem of QuickTime and string input.

Good news:

I have a workaround that you can try. The workaround involves two parts:

    [B]ONE:[/B] Create a single "dummy" blank text event that looks for string input yet 'gives up' almost immediately due to a 1 millisecond timeout. This event only needs to be created once, and then we can link it in front of each movie event. (See my "tutorial" below)

    (I found that it was also necessary to link the blank event in front of event “Qn49”, which is the first time your experiment needed a string response following the final movie.)

    [B]TWO:[/B] Because the blank 1-millisecond event can sometimes flicker briefly, I have adjusted the width of your string input to 720 (it was previously 800) so that any flicker is completely obscured behind the movies. The movies have a width of 720.

Here’s a short “tutorial” video to clarify:

My demo video is about one minute long. You can pause it as you follow along if you find that the tutorial proceeds too quickly.

Hi Kelly,

Thank you for the prompt response and fantastic support. I viewed your tutorial video, tried the workaround and the string input box now appears! Your help is greatly appreciated.

Best regards,

This issue has been fixed in our new SuperLab 4.5.2 release.