Stimtracker could not detect usb connection via D2XX

Hi there,

I’ve sent an email a few days back via the cedrus website documenting the exact nature of an issue with the cedrus stimtracker. I do not have immediate access to the workstation currently, so I will try my best elaborate the problem as accurately as possible right here.

The workstation is using a linux ubuntu 18.04 setup, presenting stimulus using the latest Psychopy3 version with the pyxid2 module. I have installed the D2XX drivers via

The workstation could not detect connection to the stimtracker, producing the error (not the exact error message but something along the lines of) “D2XX: D2XX: Can’t find connection” when running the “devices = pyxid2.get_xid_devices()” command. However, running the “lsusb” command on the terminal detected the connection between the linux PC with the stimtracker, showing up as:

'Bus 003 Device 012: ID 0403:6001 Future Technology Devices International, Ltd FT232 USB-Serial (UART) IC ’

I have tried various solutions online, including all steps as shown in the video, but it still doesn’t fix the issue.

A separate windows computer could connect with the stimtracker, so this is most definitely not an issue with the stimtracker.

Does anyone have any idea on how to remedy this?

Hello Aaron,

Cedrus does not support the Linux OS due to lack of demand. I asked a developer to look at your question and he didn’t see anything obvious. I’m sorry.

I will suggest the following tip that might help. FTDI makes two drivers: VCP (Virtual COM Port) and D2XX. On Windows, the two drivers can co-exist peacefully. However, on the Mac, they are mutually exclusive: if the VCP driver is installed, the D2XX driver will not work. As the Mac is Unix-based, perhaps it’s the same issue for your Linux computer.

If you find a solution, other forum visitors will appreciate an update from you.

– Hisham