Runtime Error when detecting RB-730


This issue is separate from the one I posted about earlier, or at least it’s on a different machine and using a different response pad.

When I plug in the response pad, XP detects it as “USB <-> serial” and not “RB-x30 Response Pad.” Despite this, I went through the steps to uninstalled and reinstalled the drivers according to the directions given on the Cedrus support webpage.

When I run SuperLab’s auto detect function, it gives me the following message: SuperLab found an XID device attached to this computer but it is either not the “RB-x30 Response Pad” or it is not in XID mode.

When I try running an E-Prime program that requires the response pad (after selecting the correct port), I get the following error:

Runtime Error!
An error occurred while attempting to open the device
Device Name: SRBOX
Error: 0x00004a49
Message: ‘Unable to open the SRBOX: 0x00000005
The SRBox Device Driver may not be installed’

Line: 1539
Error Number: 10051

I tried switching USB ports but it hasn’t worked. Any suggestions?

Having Windows XP display “USB <-> serial” is normal and correct for all response pads shipped from September 2010 onward.

SuperLab’s auto-detect feature will properly identify the response pad if all the DIP switches (the ones next to the USB connector on the pad) are all down. I’m guessing you probably had switch 1 up for E-Prime compatibility.

Regarding the E-Prime error message, please see my reply to this forum post. You are probably running into the same issue.

The response pad was actually shipped before September 2010 and used to be displayed as “RB-x30 Response Pad” in the hardware devices list.

Also, I’m still receiving the E-Prime error message despite the fact that I have two entries under the section Other devices in my device manager.

However, you were right about the DIP switches, SuperLab detected the response pad when all the switches were down.

So the device is being detected correctly by SuperLab, but it’s being detected “USB <-> serial” unlike before, and E-Prime still gives me the error despite the fact that the port number and baud rate are correct in the E-Prime settings. I have tried configuring the switches on the response pad for 9600 baud instead of 19200 and changing the E-Prime device settings for 9600 baud as well, but changing the baud rate only made E-Prime give me a new error, saying the baud rate was invalid.

I’m not sure what further advice I can offer here… The fact that SuperLab is capable of auto-detecting the response pad means that the USB driver is properly installed. As a last resort, I suggest that you uninstall the PST drivers and re-install them.