RB-830 set up


I have been trying to set up A RB-830 response device in NBS Presentation however have encountered a few issues.

We have recently updated our operating system from xp to windows 7 and have installed both the Cedrus Xid response extension and the USB driver for the response pad. However, when following the steps for adding the device to the response devices list we have not had much success. When trying to register
a new extension it will come up with the following error message:

[B]"There was an error registering this file with Windows:

The file C:\Program Files (x86)\Cedrus XID Response Extension for Presentation\CedrusXidDriver.dll could not be loaded.
Windows returned the following error:
The specified module could not be found.

Please contact the extension provider for help."[/B]

If we select don’t register server with Windows it allows us to successfully register the extension. However, when we then try to re-enumerate devices it comes up with the following error:

“Unable to create response device extension cedrus:
An attempt was made to create a COM object for a class that is not registered:
Interface ID: {7F2C1D70-B69A-4488-817E-17140910773B}
Class ID {AF16F32C-DC86-4877-B236-422F750978A2}”

The device is listed in the device manager on the computer so it is definitely being recognised. The device previously worked on xp and We have managed to get it set up on another computer with the windows 7 OS so I am confident there is
nothing fundamentally wrong with the device. However, we have followed all of the same steps on the computer we need the device on and can not get it to work. The only thing that I could see that was obviously different was when the extension was
registered something came up in the Threading column - this does not happen on the other computer we are trying to set the device up on. I don’t know if there is some other software that we need to have installed on the computer to get it working.

We have also tried using different versions of presentation and tried uninstalling and reinstalling the drivers but have not had much luck with this either.

Any suggestions on how to fix this and get the device up and running would be greatly appreciated.

Thank you,


Hi Sarah,

From what you have described, it seems like the problem is with CedrusXidDriver.dll and not with the actual RB-830 response box.

We have not heard of this problem prior to your report. Here are some recommendations that we have for now. We will seek further ways to help if nothing below eliminates the error.

Recommendation 1: if NBS Presentation provides more than one installer, please use the NBS installer that is 32-bit. CedrusXidDriver.dll is a 32-bit DLL. I would expect this kind of “COM class not registered” problem to appear if a 64-bit NBS program were trying to cooperate with a 32-bit Cedrus extension dll.

Recommendation 2: Use the latest Cedrus extension, available here:

(search that web page for the section: “Download and Install Extension DLL”)

Please remove any prior content from the “C:\Program Files (x86)\Cedrus XID Response Extension for Presentation” folder before you run the installer.

Recommendation 3: install the Microsoft C++ Redistributable Package from this link:


(Our next version of the CedrusXidDriver.dll installer will automatically provide the C++ Redistributable Package. Our current installer lacks such a provision, so you may need to obtain that package from the Microsoft link (above), unless any other software on your system already installed with the Redistributable Package included.)

Please let us know if any of these recommendations is helpful.


Thank you for your help. I managed to resolve the issue by installing an older version of the C++ redistributable package :slight_smile:


Same problems


We encountered exactly the same error as mentioned above. We tried all given options, but none work. We work with a Response pad 740.


Renee, are you using the latest version of the Presentation extension listed on this web page?