Rb-830 & 834

have received the RB-830 & 834 pads two days ago (april 26 2011) and tried to connect them to a PC running Windows 7 64 bits as it was noted they should work but no way… On the support pages I have found the guide for resetting the pads, and run it on a Windows 7 32 bits computer as requested but it doesn’t seem to work as well. Could it be because it has windows 7 starter on it?
Thanks in advance

We don’t think this could happen cause of the Windows 7 starter. Is it giving you a an error message? It is telling you to install the drivers?

Hi and thank you
in the end I managed to get the response pads working by following the steps listed here http://www.cedrus.com/support/rb_series/tn1059_mprog.htm on a computer with Windows XP on. Both pads now work on windows 7 as well. Don’t know what went wrong before…
I am still a bit puzzled that drivers download was needed as I only received the pads a couple of weeks ago, so I expect they were shipped after September 2010 :rolleyes:

RB 830 Driver

I am having the same problem using just arrived RB 830 Response Pad with Windows XP. Ran the uninstall program, the new drivers were reported to be installed. I am able to open M Prog but it fails to load when I click the Magnifying Glass icon as detailed in the instructions.

Response pads still not working…


If you’ve just received your response pad, you shouldn’t need to run the MProg program. Windows should just recognize it and install one of its built-in drivers.

I know - I wish it were so… When I plug in the RB pad Windows fails to recognize and asks to select a driver automatically…

What happened afterwards? did you let Windows chose the driver automatically?

Windows tell me that it can not find a driver and to see the installation DVD that came with the hardware.

Please call or send me a private message with your email address. This might be faster resolved over the phone. (+1.310.548.9595)

an additional problem

I have updated the response pads to work with Windows 7 and they work fine now.
However, last week I tried to connect them with another computer running Windows XP and it seems impossible to use them there. When I connect the response pad to the computer I get a message asking to select a driver: as there was no CD included with the pad, I allow windows to search for drivers on the web but it fails to find them. In the end I get an error message saying the hardware has not been recognized and SuperLab won’t see the response pads. Any ideas?
Thank you very much

Try downloading the FTDI under x86 (32-bit) for Windows from the link below.