RB-530 and E-Prime: detection trouble


We’ve recently purchased a Cedrus RB-530 response pad, claimed to be compatible with E-Prime through the SRBox 200A emulation. I’ve followed all the steps from the website in order to make it work with E-Prime. The pad works perfectly with Xidon in default mode (all pins down). The driver were of course installed properly. I upgraded the firmware to RBX30_c18.hex - file which was included in the downloadable Xidon of the support site (it was c18, not c14c as the site requested, but I thought it would be a finer upgrade). I then tested the 19200 and 9600 baud modes with E-Prime, using the SRBox default script which comes included with E-Prime 1.1.

It works fine in some PCs, but does not work at all in others. The pad is detected always with Xidon with the pins down, but not detected by some PCs in the 19200 mode. The message thrown by E-Prime is this:

Run-time Error (Line 462)
10051: An error occurred while attempting to open the device
Error: 0x00004a49
Message: ‘Unable to open the SRBOX: 0x00000005
The SRBox Device Driver may not be installed’

And in 9600 mode, it states that the baud value is not correct/valid. So, basically, I can only work in some PCs, and never in 9600 mode. What is happening with the pad?


        Fabrizio Ferri Benedetti
        University of Valencia

Hi Fabrizio,

When the USB driver for the response pad is installed, it emulates a serial port. Unfortunately, we have no control over the COM port’s number; it is assigned by Windows automatically. If it’s higher than COM4, it will not work with E-Prime. To reassign the COM port number to within E-Prime’s range, see the support document Determining or Changing the USB Driver’s COM Port Setting.

Regarding the 9600 baud mode, I believe that it used to work with E-Prime 1.0 but stopped working with version 1.1. We have not gone back to the drawing board to see what’s up, mainly because most people prefer to use the faster baud rate anyway.


Ports changed

Hello Hisham,

thanks for the prompt answer. I’ve tried to change ports, but the problem continues with some PCs (using COM from 1 to 4). Perhaps a problem with serial port emulation? A conflict between port numbers in use? It’s odd that in some PC works perfectly and in others don’t…

Kind regards,


Hi Fabrizio,

I wish I had an answer for you, but it’s difficult to trouble-shoot the problem short of being there with you. Also, I am wondering if E-Prime’s error means that E-Prime was not able to open the serial port, or whether it means that it was able to open it but did not detect an SRBox. Do you know?



Hi Hisham,

I’ve sent a mail with the error message to the E-Prime official mailing list. I hope that someone will catch up the message and reply. On the hander hand, should I try other options? What if I try some programs checking for serial port communications (like Serial Monitor and the like)?



Tried a couple of things

No success so far with this laptop.

What puzzles me is that the green light is on. If I put all pins down (XID Mode), Xidon perfectly detects the pad. So I suppose that there must be a problem with E-Prime and/or 19200 mode. Could I execute some tests with Xidon without harming the pad? Should Xidon detect the pad in 19200 or 9600 mode? I ask this because Xidon does NOT detect the pad in such modes (apart from a slight delay during detection process, noticeable on the PCs with which the pad works - there is no such delay on my laptop).

While I understand that RB pads are designed to work with SuperLab out-of-the-box, it’s a shame that with E-Prime one finds that strange issues. I really wonder what’s going on…



The USB drivers work

If Xidon is detecting the response pad, this means that the USB drivers are working just fine.

Could I execute some tests with Xidon without harming the pad? Should Xidon detect the pad in 19200 or 9600 mode?

Yes, I don’t see how you can harm the pad, they are built solid. When in XID mode, switch 3 changes between 9600 and 115K baud – 19200 is not used. See http://www.cedrus.com/support/rb_series/tn1044_dip_switches.htm.

We need to take a closer look at the E-Prime issue. The RB response pads work by emulating PST’s Serial Response Box (SRB). The SRB floods the serial port with 800 or 1600 characters per second. My best guess as to what’s going on is that E-Prime 1.1 tries to detect the incoming character rate. If it’s out of range from what it expects, it complains. My hunch is that this is new in 1.1 and wasn’t there in E-Prime 1.0.

I’ll see what we can do about comparing the character rates. If my guess is correct, we can probably provide a firmware upgrade that can fix this issue, but it would be a couple of weeks before anything happens.


About the upgrade

Well, a firmware upgrade addressing this issue would be definitely worth a try. Thanks Hisham!

On the other hand, my only concern was about damaging in some way the firmware or some internal setup while tampering around with Xidon or other apps. I don’t know how “robust” is the core of a RB pad. Meanwhile, I’ll try to use E-Prime in 9600 mode by changing the 3rd switch. I’ll let you know what happen.



Don’t worry, you cannot damage the firmware. :slight_smile: The core is very robust.