Problem Using RB-730 with E-Prime

I am having a problem with two RB-730 reponse pads.

They were both working fine at first. One had been working on this XP machine for a while, and I tried the other one in the same machine, which worked also. So far so good. But then when I tried plugging in the original reponse pad back into the machine, it asked me to install the drivers for the RB-x30 Reponse Pad (not yet called “USB <-> serial”). I did this following the directions at, and the drivers seemed to install fine, but the button box wasn’t being detected by EP (I was getting the following error: error 00004a49, unable to open SRbox 0x00000005, error #10051). I rebooted, and now when I plug in the reponse pad it detects it as “USB <-> serial.” The same thing is happening with the other response pad. Needless to say, EP isn’t detecting them. Any clue what’s going on?

I recommend doing the following two steps.

Step 1. To determine if the USB drivers are installed correctly, download SuperLab. Within SuperLab, go to the Experiment menu, Participant Input, then check the RB-x30 Series Response Pad option. There is a Setup tab on the top of the window, here is where you will find the Auto Detect button.

If SuperLab is able to auto detect the response pad the drivers are working.

Step 2: Make sure the COM port number that is listed in the device manager matches what you have set in E-Prime. Most likely they will be different because of the installation of the USB drivers. For more information on determining the COM port number please see the link below.

If the steps above do not work then see thread 1226.

Thanks for your help. I uninstalled the drivers then re-installed again. When I ran the auto-detect function in SuperLab I got the following message: SuperLab found an XID device attached to this computer but it is either not the “RB-x30 Response Pad” or it is not in XID mode.

E-Prime is detecting button presses on the response pad though. It seems to be working fine now.