movies, single key response and string response

My movie files seem to be interfering with my string response events. Events that require a string response don’t show the text box. I’m using SL 4.0.7

I’ve got a script that requires responses in the form of both single key and string. It also includes two video files. Those are currently set to require a correct response OR a time limit, set to 100 ms. (My experience has been that if any event requires a correct response, all of them do, particularly when mixing single key and string, so the idea is participants COULD enter a response but the time limit will prevent them from HAVING to). The problem is that the screens that ask for string responses (following the movie events) don’t show the text box or next button.

I know it’s a problem with the movie event, because everything else works fine when that event is deselected. I’ve tried changing that event to everything I can think of (no response required, just correct response required minus the time limit)… But no matter what, same problem. Script is attached. I’d appreciate any ideas…

Gender.sl4 (44.5 KB)

Regarding using String and Single Key input, the thread below might be of some help.

Also, can you send your experiment as an Experiment Package? It might be too big to post on the forums, so I will contact you directly.

Here’s the experiment package. That thread seems to simply warn against having SL look for single key / string for all events, which should not be the case with my experiment. I tried changing the movie event to a text stimulus and the experiment works fine. I think it’s something to do with the movie event type. (1.17 MB)

I also noticed that if I press escape to end the experiment but then click “no” when the “are you sure…” window appears, the string response box appears and works fine.

I tried setting up the movie event to require a STRING response or time limit of 1 ms. Before it was set to single key or time limit. This work-around seems to be effective, and I’m sure participants won’t notice the text box flashing up. However, this really does seem like a problem with SL.

Thank you for the information. I’ve opened a bug report in our case tracking system.

This issue has been fixed in our new SuperLab 4.5.2 release.