Macbook Pro - RB 834 not detected


Just bought a Macbook Pro 15" (not the new version). I installed Superlab 4.5 and then plugged in the repsonse pad RB 834 for the first time. But, no ‘A network interface has been detected’ message appeared and when I ran Superlab it could not detect the repsonse pad. Any ideas as to why there is this problem???

Thank you in advance,

Thank you for contacting us via email regarding this issue.

I’m having the same problem. After installing the driver my iMac was able to detect the RB-834. However, when I tried the same procedure with my MacBook Pro nothing happened - it isn’t showing up in Superlab or in my Network Settings.

Hopefully you have found a solution?


This question is probably faster answered over the phone. I will contact you through private message to set up a time.

I also have this problem, with a 15" Macbook Pro and an RB-730 response pad. Is there a solution yet that might work for the RB-730 also? Thanks

Have you tried installing the drivers from the link below?

Thanks for the reply. Yes, I have installed the drivers, and the green LED goes on when I connect the cedrus response box, but no ‘A network interface has been detected’ message appeared, either before or after I installed the drivers.

I’m using matlab with psychtoolbox, and I need to find the tty. and cu. files in the /dev/ folder so that I can open the serial port via matlab, but none have appeared.

The only evidence I can find that my macbook has any connection with the cedrus box is that when I use the application ‘USB prober’, there’s a USB<->serial connection listed that appears when I plug in the cedrus box.

Any further help greatly appreciated!

I recommend that you download SuperLab to see if the USB drivers are installed correctly. Within SuperLab, go to the Experiment menu, Participant Input, then check the RB-x30 Series Response Pad option. There is a Setup tab on the top of the window, here is where you will find the Auto Detect button.

If SuperLab is able to auto detect the response pad the drivers are working.

Thanks for the advice. I downloaded SuperLab and tried to autodetect the device. Initially I had bluetooth enabled on my computer and when SuperLab was scanning for a device I got many requests to pair a bluetooth device, where my mac was prompting me to enter a passcode from the bluetooth device to enable pairing. I quit SuperLab, turned off bluetooth, then repeated the process.

This time SuperLab scanned then returned a message that the Response Pad wasn’t found, nor any other XID device.

I also reinstalled the drivers, was told the installation was successful, but got the same result when I tried to auto connect.

This will most likely be faster answered over the phone. I will contact you through private message to set up a time.

Please post a fix so the rest of us can benefit

I also am trying to get an RB-834 response pad to work with a newly purchased MacBook. Exactly the same symptoms as the original poster. Please take the time to post the solution to this problem here in the support forum. Others will probably be encountering this problem and will likely turn to this forum hoping to find an explanation and a fix.

Was hoping to get a simple demonstration up and running in a couple of days.

The solution was to use a more up-to-date driver which you can obtain from the following link: