Issue detecting scanner trigger in XID mode with Lumina 3G


This is a bit related to Lumina 3G controller often not detected in PsychoPy and Presentation but a different issue.

I managed to setup using Presentation 22.1 build 04.30.21 and the Cedrus Lumina 3G response button with the Presentation extension in XID mode. This worked out of the box meaning that when Lumina 3G Scanner On input is selected as fMRI port, everything worked fine.

Last week I updated to the most recent Presentation 24.0 build 07.19.23 and encountered a strange issue.
The trigger from the scanner is not working properly anymore in XID mode. After some testing I managed to make it work using a detour:

  1. Check the Scanner On Trigger as fMRI port
  2. Test port settings
  3. Click Go on Quick Monitor
    => Scanner trigger is not detected, the Scanner counter is stuck at 0
  4. Click Stop
  5. Click Go
    => Scanner trigger is detected, the Scanner counter increments but does not start at 1 but at a higher number!
    I now can run the paradigm with scanner triggering.

The scanner pulse is detected in Xidon and an oscilloscope shows a TTL pulse.
Setting the Lumina 3G in keyboard mode works perfectly.
XID mode works perfectly in PsychoPy.

I downgraded Presentation to 22.1 to check if this was a version-specific issue but this version now also shows the same issue.
I then uninstalled all Presentation versions and did a deep clean of the registry. Reinstalling v22.1 did not solve the problem.

Our scanner trigger is converted from optical to TTL using an Arduino. We can simulate scanner pulses by pushing a button. Strangely, this works very well while the real scanner pulse is not detected by Presentation although the signal is exactly the same. Remark again: PsychoPy and other tools work perfectly fine.

I have absolutely no clue what is going on. The fact that other software runs without issues indicates the problem might be related to the upgrade from Presentation. It is just strange that removing Presentation and installing the old version again does not resolve the issue. Could this be a hardware related issue or have something to do with the extension?

We have a Dell XPS 8940 running a fully patched Windows 10.

This is puzzling indeed. I don’t have a ready answer but can offer some observations and questions.

  • Just to be on the safe side, does our Xidon software detect the scanner trigger? From what you described, I’m guessing “yes”, but I’m trying to cover all bases.

  • Speaking of Xidon, when it detects the Lumina controller, it will show the firmware version number. If you are not using the latest version 2.2.9, I recommend you update the firmware

  • Just an observation that you are likely aware of already. :grinning: Simulating scanner pulses by pushing a button is OK up to a point but is not representative. When pressed, a button establishes contact for 1 to 10 milliseconds, depending on the switch size and quality. But on a Siemens scanner, for example, the scanner trigger is typically just 20µs – at least 50 times shorter. But since you have software that is detecting trigger pulses, we know that the Arduino converter is not the issue here.

  • I am curious as to why you used an Arduino to convert from TTL to optical when such a feature is built into the Lumina 3G controller

If you resolve the issue, please do post a follow up. You got me curious.

Hi Hisham,

Answers on your questions:

  1. Xidon does detect the triggers without problems. I have tested this many times and the outcome is stable, so nothing on this side.
  2. The Lumina has been updated to the latest version
  3. We have multiple devices which need triggering from the scanner Lumina, physiological monitoring, eye tracker, audio system, MR elastography device) which have different requirements on the length of the TTL pulse.
    A colleague built a very nice system based on an Arduino which receives optical or electrical signals (with or without galvanic isolation) as input. The input signal is converted to two outputs that we call RAW which have the same pulse lenght as the output. The Arduino is bypassed here. Eight outputs are controlled by the Arduino where the user can set the output pulse length. Some older equipment needs longer pulses. Each output has a simulation button. Pressing the button generates an output signal with the duration programmed in the Arduino so it is an exact copy of the output pulse generated by the scanner trigger input . The Lumina is also connected to this system. It receives a pulse of 10ms.
  4. The reason we don’t use the Lumina for the pulse is because it does not output an electrical signal and we need multiple customizalbe pulse durations.

It is possible for the Lumina 3G controller to output an electric pulse using an m-pod.

We don’t have an m-pod because it does not meet our requirements. The Lumina worked perfectly for a long time but is now failing. The fact that is works with PsychoPy and other tools and not in Presentation means that there must be an incompatibility between the software and the extension. Rolling back to an older version of Presentation did not resolve the issue so I suspect this can have something to do with the Extension. However, I am not an expert on this, I just would like to get this resolved.

I just wanted to know if this issue has been checked.
The current setup is not stable and researchers are complaining about it.

We have since updated the Presentation extension on Sept 22nd; see this page.

I would be very curious to know if this fixes your issue. The update is meant to fix some installation issues that people have been running into. But once installed, we never had a report of the Lumina controller failing to communicate with Presentation.