Installing RB530 on Windows 10 64bit


I am having problems installing an RB530 button box on my new lab computer, which runs on Win10 64bit.

When I plug in the box, the computer automatically finds RB-x30 button box and adds it to my hardware without the drivers. When I want to go and “update drivers” from my folder (they come presaved on the display++ drive), I get an error. I downloaded the drivers from the website but it didn’t work for them either. I also tried disabling the automatic driver installation, but it doesn’t seem to get me to have the “install drivers wizard” in spite of the settings being saved.

Most of my equipment was purchased roundabout 2009-2011 so I suspect my troubles might stem from this. There is a workaround on the website, but it says it only helps with 32bit windows. I did try it but I hit the same bottleneck, namely, that my windows automatically adds a driverless RB530 under “other device” in device manager and then doesn’t let me update the drivers.

Has anyone had a similar problem?
Are there different drivers that I should try and if yes what is the link to them?

Thank you for reading this, I look forward to receiving your help!


I still have the same problem.

I performed the update of my button box to post-2011, as explained on the website.

now, it installs the COM port but it does not install the button box driver when I plug it in.

So, it’s back to square one. I tried manually installing the batch file with the FTID drivers provided, but they install correctly and yet I still do not see the device - probably as it is not actually detected as new hardware and so I cannot access it to update the drivers directly there.

Has anyone encountered/resolved a similar problem?

I look forward to hearing from you!

thanks in advance