Artifacts in EEG recoding from button press


we are using a Cedrus RB-530 response pad while recording EEG with an EGI sensor net in a reaction time task.

We have noticed that every time the subject presses a button of the pad an artifact (around 6 mV) appears in the EEG signal. We know that it is not elicited by finger movement.

Anybody has noticed anything similar in the EEG recording?

What can we do to avoid these kind of artifacts?

Thanks a lot!

Is the RB-530 connected to EGI via the Accessory Connector?

Artifacts in EEG recoding from button press

Hi Hisham,

no, we use a USB connection between the response pad and a computer with Presentation software, that is connected to EGI computer via parallel port.

After some test, we have noticed that the artifact occurs only when the person who wears the net presses the button (but not if another person without the net presses it). It seems that some voltage is transmitted from the pad troughout the subjet’s finger and we can see that voltage in several sensors of the net, specially in those around the sensor that is used as ground.

Maybe we have a problem with grounds, we have to investigate it deeply and ask EGI support but, could a voltage be trasmitted from the pad to the subject?

Thanks a lot for your attention

We’ve had another user run into this. That user was getting 3mV artifacts when the participant simply moved their hand on the response pad.

The solution is to isolate the response pad’s ground from the computer ground – easier said that done. In the case of the other user, he supplied the response pad with battery power through the USB connector and collected the data on button presses via the Accessory Connector.

Artifacts in EEG recoding from button press

Thanks a lot Hisham,

I’ll try the first option (isolate response pad’s ground from computer ground), but I really don´t know how to do it. I need some clue… Is some physically action in the computer hardware needed? or can I get it via any configuration panel of windows?

About the accessory connector, do you known the time accuracy of this kind of connection? USB connection is about 5 ms…what about the accessory connector?

Thank you for the help!

Battery power is the easiest power source to find and use that has an isolated ground. To use it:


  • Get a [B]USB cable[/B] that you won't miss.
  • Buy a [B]battery holder[/B] that can hold [B]three[/B] 1.5 volt batteries, for a total of 4.5 volts. These can be purchased at Digikey or Mouser. Radio Shack might have some. If it's too much trouble and you're handy, you can buy a flashlight that takes three batteries, dump the light bulb, and use the flashlight as a glorified battery holder. You get a free on/off switch with it. :p
  • On the USB cable, cut the connector that goes into the computer.
  • The USB cable has four conductors, or wires: two for data send/receive, one for ground, and one for positive voltage. Ignore the data wires and connect the other two to the battery holder. [/LIST] At this point, if you've done everything correctly, the other end of the USB cable is ready to plug into the response pad to power it up.

    Regarding timing, the Accessory Connector will put out the signal within 1 millisecond. So does the USB connector, but we’re not using the USB data here. Remember, the 5ms figure that you mention is due to the USB driver that’s running on the computer.

  • Batteries

    Hi Hisham,

    first of all, I’ve tried to use a battery of 9 v as of the response pad’s power source and it does’t work. Is it too much voltage? You told me that I had to use tree batteries of 1.5 v (4.5 v)… maybe using 9 v could be a problem.

    Moreover, I’ve noticed that the response pad needs the drivers to be powered (if I connect the response pad in a computer without RB drivers installed it is not powered)…I can´t install drivers in a flashlight :stuck_out_tongue:

    We had powered the response pad with a secondary PC working with battery (not plugged to the general net) and the artifact remains. We cut the ethernet cable and used their pins as serial inputs because we can’t communicate via Accessory connector.

    Finally, I’m working with Presentation software and it actually allows TCP/IP connections but it demands a hostname to work. It seems that this utility has been designed to connect two computers. Has the response pad any TCP/IP direction, any hostname? in order to get a comunication Presentation-response pad??

    Thanks a lot!!

    If you still haven’t resolved this, please call me at the office on or after July 15 (I’m out of the office until then). Some issues are faster resolved over the phone. 1.800.CEDRUS1 (that’s 1.800.233.7871).

    Artifacts in EEG recoding from button press

    Hello, I was conducting an internet search of a button press artifact when I came across this thread. My lab is currently using an EGI system to collect EEG data and several of the tasks that we have designed requires a response. We have been using the Cedrus response box (RB-540) and have noticed an artifact like the one described in this post. We have also tried an external keypad and noticed it as well. I was interested if there was a solution to this problem. Attached is an image of the artifact where the where in the green and blue line condition the participant is pressing a button that results in a tone (occurring at 0ms). Thank you in advance for your time.


    It’s hard to troubleshoot at a distance, so perhaps some questions first. :slight_smile:

    1. How is your RB-540 connected to EGI? are you using m-pod?

    2. Does your USB cable have ferrite cores on it? These look like the round white blocks in the picture below that are clamped near the connectors on each end.

    3. If I may ask, where are you geographically located?

    Thank you for your response. To address your questions:

    1. Our lab is not using an m-pod. The EEG acquisition, stimulus presentation, and the participant are located in the same room several feet apart.

    2. We are using a USB cable that has a ferrite core. What would be the affects if our lab were to use a USB that doesn’t have this cable?

    3. The lab is located at the Icahn School of Medicine at Mount Sinai in New York

    1. If not using an m-pod, how is the output of the RB-540 connected to EGI? Feel free to post a picture.

    2. The ferrite cores boost noise immunity.

    The Cedrus response box is connected to a PC presentation stimulus computer via the USB connector (we use a USB extension cable). The stimulus presentation software that we use is Neurobehavioral Systems Presentation which takes as input the response pad and outputs to the EGI system via a parallel port that goes through an EGI AV device to a serial port. This serial port is connected to the EGI AMP that then through a fiber optic cable goes to a switch box to an ethernet cable to the EEG acquisition computer.

    Just to add the extension USB cable does not have the ferrite cores.

    The fact that this happens when using an external keypad as well makes me think that the issue is not with the response pad, but rather elsewhere with the PC or the cabling.

    A potential source of trouble might be the USB extension cable. How long is it?

    I ask because the USB standard is a “desktop” bus, meaning that it was designed for devices that can be found on your desktop. The length of USB cables is limited to about 10 feet. Beyond that, you will need to use a powered USB repeater. This is a device that receives the USB signal and amplifies it so it can travel further.

    I wasn’t able to find the brand of the USB extension but it’s about 6 feet. I also heard of people braiding wires to help minimize electromagnetic interference. Would you recommend that?