Write permission

In the macbooks in our lab, we have set up two user accounts, admin and exp. Admin is, well, an administrative account, and exp is not. Our RAs all log in as exp, only I login as admin.

I installed SuperLab on the machines as admin, which worked fine, but then when the RAs started running experiments as exp, we began to get a startup error message “unable to create temp file, no write permission, unable to create configuration file” (the error message isn’t exact, it’s from memory). I fiddled around with it and eventually figured out that any user who uses Superlab has to have write access to the Superlab directory in /Applications, if not, they get that error message. What I did was to turn on group write permission and changed group ownership from staff to exp for the whole Superlab hierarchy under /Applications, after that, the error messages went away for both admin and exp. This wouldn’t work in most cases, just in a case like mine where there is a total of two user accounts that need Superlab. The “best” solution given the need to write in /Applications would probably be to use a special superlab group code or to enable acl’s.

In general, though, I’d prefer to not be scribbling under /Applications every time the program runs. Perhaps Superlab could be changed in a future version not to do that(?).


This is an issue that I am aware of and working on. It’s new to 4.0.2 and is caused by an improperly implemented feature that was supposed to make SuperLab smarter about remembering the registered owner across users… but I missed a tiny little detail, and non-admin users get this message on startup. It’s annoying but harmless.