SuperLab was unable to open the microphone device.


I was trying to make an emotional Stroop task where the participant makes responses by their voice.
However, I kept on receiving an error saying that SuperLab was unable to open the microphone device.

I selected the internal microphone as the input.
Could you help me out with this?

Thank you,

Within your computer’s System Preferences, does the Internal microphone work? If it’s not working within System Preferences it also will not work in SuperLab.

Thank you for your reply.

It seems that the internal microphone is working fine. I see the input level indicator working very well on System Preference.

superlaberror.pdf (70.9 KB)

Thank you for the screenshot. As shown in the screenshot, the popup from
SuperLab contains the text:

“More information may appear below”

and there is a “Details” button.

Please click the “Details” button. When you click “Details,” the error window will expand, and there will appear a “Copy” button on the bottom edge. Click “Copy” and then please paste all the text so that we can see the full output from this error window.

Other things to consider: is there another application running (such as Skype) that may have control over the microphone? Try to close any such applications, and then re-launch SuperLab and try again.

Thank you for your reply,

I found that Skype was running when I tested the microphone.
So, I closed Skype and SuperLab. Then, I opened Superlab and tested again, which resulted to the same problem.

I have copied and pasted the details of the pop-up window here:

13:49:45: Microphone SPB problem starting experiment. Code: -221. Message: invalid index passed to SoundInGetIndexedDevice
13:49:45: SuperLab was unable to open the microphone device. More information may appear below.

Thank you,

Which specific Mac OS version are you using? Are you using a laptop or desktop? Also, do you happen to have a USB microphone (or bluetooth) that you can try plugging in and testing to see if it works?

I am using Mac OS X 10.8.5. I tried a USB microphone (Blue Snowball), but I received the same error message. My Mac is a laptop (MacBook Air).

We have tried to duplicate the issue on two different Mac desktops and one laptop (using USB mic and internal), and so far we cannot duplicate the problem. Can you try downloading SuperLab 4.5 from the link below (as the trial version) and see if the issue happens?

I used SuperLab 4.5, and the microphone worked fine.

Unable to open microphone error

We’ve seen this same error, repeatedly, on several different Macs with different microphone set-ups, including using the internal microphone on some Macs as well as external Mics. We have a SL 5 program we’ve written with which the problem occurs every time you start the program. We have another program that is basically a clone of the first one, which was then edited into a slightly different version of the first program–nothing to do with the inputs (including microphone input) was changed, though. This second program never seems to generate the ‘unable to open microphone’ error…whereas the first one always generates the error.

Here’s the thing. This error only occurs after first opening the program. When it occurs, if I go up to the ‘Experiment’ menu and select ‘Participant Input’ and then select ‘Microphone Input’ and click on the ‘Done’ button everything works fine from that point forward, which seems quite weird. I don’t have to change anything.

It’s as though when the program first starts it can’t find the microphone input but once you point it to the input it’s fine.


Rob, can you post both experiment files?

In the steps that you described where you go to Experiment menu > Participant Input, select Microphone input, and click on Done, are you saving the experiment right away afterwards? If not, please try that.

Hisham, yes I’ve clicked on the Done button and saved the experiment after that, many times, though obviously can’t do this with the runtime version of SL5. Note, though, that the error occurs with the development version of SL5 as well.

I’m not sure how you’d like me to post the experiment files. I can email them to you if you like.