SuperLab either freezing or not recognizing one button box


We are having trouble with our SuperLab experiment, which we run using an RB-740 response pad for participant input.

When running the experiment a few days ago, SuperLab seemed to run through the experiment normally until the end where it froze instead of completing. It remained stuck on a white screen with the mouse visible and able to move but unable to do anything else. I tried to quit using esc, but this did not work. I was able to pull up Task Manager with the keyboard shortcut, where it showed SuperLab as “Not Responding”, but the application still would not quit when I clicked “End Task”. The only way for me to shut down SuperLab was restarting the entire device.

Since then, it has alternated between having this freezing problem (at various timepoints) and not recognizing the response pad (thus not even being able to start/run the experiment).

Another lab in our center has two other RB-740 response pads, so I have tried running various trials of the experiment with the other button boxes as well.

I will refer to our group’s pad as RB #1, and the other groups pads as RB #2 and RB #3.

On Xidon, RB #1 is not detected; RB #2 is detected but as an RB-540, not an RB-740 as it should be; RB #3 is detected correctly as an RB-740, but an alert that the firmware is too old appears.

On Device Manager, all three appear under Ports as "USB Serial Port (COM5). RB #1 sometimes does not appear, but upon unplugging and replugging a couple times it eventually seems to appear.

On SuperLab, if RB #1 is not appearing in Device Manager, it usually states there is no response pad found and cannot run the experiment. If RB #1 is appearing in Device Manager, SuperLab freezes and goes into Not Responding mode. For RB #2, SuperLab states that the wrong kind of response pad is found (RB-540) and asks if I want to reconfigure, which I do not. RB #3 seems to work and run through the experiment successfully.

I have tried reinstalling the driver, but the problems persist. Is there any recommendation of what else I can try to get RB #1 back to functioning properly?

Thank you!

Per email exchange, your replacement response pad is on the way. :grinning: