String input sporadically works - 4.0.7b

PC running vista SP1 and SL 4.0.7b.

Trying to do string input. Sometimes it works, sometimes it doesn’t. And yes, both single key and string have the “only use this input when designated” box checked.

This script was working fine for several weeks of data collection. Then I changed a few things later in the script that had NOTHING to do with the event that accepts string input, and the script basically stops on the script event and doesn’t accept string input (I have to ESC exit out of superlab).

So I tried changing the string event to “only correct response” instead of “any response,” and restarted superlab. That worked, until I changed something later in the script that, again, had nothing to do with the even that accepts string input. So now it’s not working again. So I changed it back to “any response” and it worked, until I changed something else later in the script. Funny situation, but REALLY ANNOYING!!

What also sometimes helps this situation is restarting my computer. What is going on!?

Now it seems like the only thing that makes the string event work again is if I restart my computer and don’t edit anything in the script, and don’t re-save the script. If I edit or re-save, the string input event shows on the screen with the text entry box, but I can’t enter anything and I am forced to exit out of the program. Then I have to restart the computer to get it to work again!?


Can you post your experiment? Please post as an Experiment Package, which can be found under the File menu within SuperLab.