Stimulus List with wav files


I am trying to set up a rating task: first, I need to present a wav file, next, a screen comes up with 5 response alternatives (picture file). I am recording response times from the onset of the picture file that I am presenting. Given that I have over 700 audio files I would like to prevent from inserting each trial/event separately; however, the stimulus list function does not seem to output the name of the wav file that was presented if reaction times are recorded from the onset of the picture file (i.e. event name doesn’t list wav file presented, but only lists the name of the picture file that shows the response alternatives). Is there any way around this?

Alternatively, is it possible to read in a simple text file into superlab which contains all the names of all the trials/events that will be used in the experiment (so I don’t have to type my 700+ events/trials?


Without seeing the experiment it sounds like the sound file is set to end “Immediately after the event is presented” under the Input tab. It is not possible to have the sound file on the same line as the picture. However, it is possible to have an additional line proceed the picture file line by changing the settings on the sound file event from, “End Immediately after the event is presented” to end on a time limit and giving it a time limit of 1 ms.

Thanks - that fixed my problem.

However, I came across something else now: Given that I am working with stimulus lists (for the first time), I am trying to make sure that an equal number of trials/events are presented (randomly) in 9 blocks. So far, I only managed to randomly present my trials in one block. How can I make sure that events from all stimulus lists (16 in total) are presented throughout different blocks?

Just to clarify: I am trying to make use of the Expression Editor function. So I would like to make sure that out of my 18 stimulus lists (which each contain 40 sound files), superlab randomly selects 5 files for each of my 8 blocks and then makes sure that the files that have already been played are not played again in another block (so that at the end of the experiment, all 720 files distributed over 18 stimulus lists have been presented.
Thanks for any advice.

There is an experiment posted under “Sample Experiments” in the forums that will help you a great deal:

In regards to having only one of your files being played once, this will be set up in the Trial Editor’s “When to Run” tab. Create an expression “Number of times This Trial Has Been Presented” is “Equal” to 0.