sound files cut off

I am running Superlab 4.5.3 on a Mac to create experiments, then running the experiments on PCs running Superlab 4.5.3 run-only. Previously, I had no problems with this setup. Recently, however, some of my sound files are being cut off during presentation, either at the beginning, the end, or sometimes both ends of the files. These are short duration sound files for monosyllabic words, around 250ms long. They are saved in .wav file format, which is what I have always used. Why are these files now being cut off?


It would be helpful to see your experiment. Please post your experiment as an Experiment Package. This can be found under the File menu within SuperLab.

I think it has to do with the size of the audio files. It appears that all files that are less than 30 kb are having this issue. They play fine as individual files on the PC, as files in SL on the Mac, but not in the SL experiment on the PC. I don’t think it’s an issue with the experiment itself, but with the way the SL on the PC is handling short sound files. (332 KB)

You have set up your experiment correctly. There most likley is a bug happening with short .wav files on Windows. Thank you for contacting us about this, the software developers are now looking into it.

In the meantime, there is a work around to stop the audio events from being cut off.

  • On each audio event, uncheck "Wait for audio to finish playing" and instead choose, "Stop audio when the [B]"trial"[/B] ends"
When this was tested, the time limit was also changed on the time-limited audio events to 600 ms. You should probably test with a few different time-limit durations until you find something that works well for you.

Thanks for looking into this issue so thoroughly. I will test your suggestion on the PCs when I return to campus on Monday.

I tried the workaround that you suggested, and the files are now overlapping each other during the trial both on the Mac and in the PC, which is not appropriate for the experiment. Did I do something wrong? I need each sound file to play individually, wait a specified amount of time, and then play the next file.

1213m01roAXBmono (333 KB)

You need to adjust the time limit on the audio events, particularly the events “ShadowedFirst” and “ReadFirst.” Right now, the time limit is shorter than the length of the audio clip, which is why a the audio files are overlapping.

I had mentioned that we tested with a time limit of 600 ms. You are free to change the time limit. However, make sure that the time limit is longer than your longest audio clip.

I didn’t understand what you meant about the time-limit change. Unfortunately, changing the time-limit will not be acceptable for this experiment. We need to have the audio file play (for however long it needs), then have a 200ms delay, then the next audio file, then a 200ms delay, then the final audio file. Setting the exp up the way you suggest would create a variable delay between audio files, which is not acceptable. Is there really no other way to get this to work on the PC run-only version? It works just fine on the Mac.

Thank you for explaining about the time limit requirements. We have a new workaround that should resolve this. In SuperLab, we can use the movie event to handle audio files. In most cases it is more efficient to use the Audio Event type for (non-visual) audio files. However, since there is a bug affecting your audio clips, we suggest the movie plugin in your case.

The attached sl4 file is based on your original Sept 24 attachment. The only change is that we created movie stimulus lists to replace your audio lists. All other time limits and settings have been kept identical to your Sept 24 settings.

One further suggestion:
Try going to the main menu, then the Experiment menu, Options, then Memory Management. Here select “Load all stimulus files before running the experiment.” The effect of that setting varies depending on the RAM and hard-drive speed of your computer. However, in some cases it results in smoother audio and movie playback. Please try it and save that setting if it helps on your computer.

as_movies_1213m01roAXBmono.sl4 (15 KB)

Thank you for continuing to work with me on this issue. I was able to test this out on my Mac today. I haven’t had a chance to check it on the PCs, but it is not working on the Mac. The version you made did not include the stimuli, and couldn’t find them at first because it was looking for them on your drive. I had to place your modified version in the same folder as my stimulus folders and edit the Stimulus lists so that they pointed to my stimulus folders. After doing this, it still will not run on my Mac. I have attached the error log. Is this version you created supposed to work on both formats or on PC only? I noticed that the files it was looking for in your version were still in .wav format.

as_movies_1213m01roAXBmono (4.61 KB)

log.txt (2.1 KB)

I apologize about the missing files. Please try again with the sl4 that was uploaded names “as_movies_1213m01roAXBmono.sl4”

Please do not edit the lists that we created in “as_movies_1213m01roAXBmono” instead, please locate the missing files using the Locate Missing Files window that shows up when you first open the experiment.

Once the Locate Missing Files dialog shows “Missing Files: 0”, then “as_movies_1213m01roAXBmono” will work on both Mac and Windows. We
tested it on both.