Responding Causes Delay in Experiment


I’ve created an experiment where participants are presented with a cue, which is paired with a thermal stimulus delivered from an external stimulator. After my participants receive the thermal stimulus they are prompted to answer a series of questions relating to how they experienced the thermal stimulation.

When my participants do not respond, the timing between everything is perfect. However, when they respond, there is a delay of about half a second before the next event in my experiment, which then increases the longer the experiment runs.

I understand that there will be a delay as SuperLab records and saves the responses of my participants, but shouldn’t this delay be consistent throughout the experiment? Is there an easy way to fix the timing of my events?

Any and all advice/assistance would be greatly appreciated.

It would be helpful if I could look at the settings. Can you post your experiment as an Experiment Package? This is found under the File menu within SuperLab. Also, what is the “external stimulator” you are using with SuperLab?

Hi Monika,

Apologies for the delay in responding to your post. I have attached the experiment package to this reply. We are using a Medoc Pathway system as our external stimulator.

Please do not hesitate if you require further information.


Pain Anxiety (223 KB)

On the events “Rating 1, 2, and 3” they are all providing a feedback of a low volume beep. The beep is 400 ms long, could this be causing the delay?

I have trialled the experiment with the “wait for sound file to finish playing” box in the event editor unchecked, and if I respond to the prompted ratings following the delivery of the stimulus there are still delays (even if SuperLab is instructed not to save the data before the experiment runs).

I ran the experiment and could not duplicate the issue. Please call us at (800) 233-7871 at your earliest convenience so we can troubleshoot over the phone.

Hi Monkia,

Thanks for your assistance, but phone troubleshooting may be difficult as I am located in Australia.

After discussions with other users, removing the feedback beep appears to resolve the issue.

Again, thank you for your assistance.