problem manually activating Superlab licences

I am attempting to renew two of our Superlab licences. The superlab program returns an error of “Port 5972 blocked” so I used the manual activation method.
i saved the activation request file, uploaded it to ‘’ & downloaded the activation file. But the Superlab program gave an error of “failed to apply activation”. I upgraded Superlab to v5.0.4 and tried the manual activation again to no avail.

When I log onto the ‘’ page it now returns a message stating that “We cannot find record of you owning licenses to the product you’re trying to register.”

In looking at your record in our license registration system, I don’t see that you own a SuperLab 5 license. I think that you will find it a worthwhile upgrade, but meanwhile, you can obtain the latest SuperLab 4.5 version from this page:

If you think that your record in our system is incorrect and you did purchase an upgrade to version 5, please call (1-800-Cedrus1) or send us an email.

Thanks Hisham,
that sorted it. When the licence activation advised updating the software to the latest version I mistakenly downloaded v5. When I ran v4.5 it accepted the licences.

thanks again.