Preview characters in self-paced reading

Hi. I hope I might get a quick reply before the SuperLab Workshop I’m leading tomorrow.

I have the most basic of difficulties with a non-cumulative self-paced reading experiment that I’m creating in SuperLab 5.0.5 (MacOSX 10.11.6 “El Capitan”, 13" MBPro). At the start of each trial, only the first word of a stimulus sentence appears, with no preview characters to the right. With each successive keypress, the next word correctly appears, with the preceding word being correctly replaced by a “preview” (postview?) character. Everything works as expected except for the absence of the preview characters to the right of the currently presented word.

I’ve tried changing fonts (Times, Helvetica), changing preview characters (underscore, hyphen, dash, asterisk), changing between Stimulus Lists (my preferred design) and fixed individual Events. I’ve tried changing settings for Erase Screen and for At Event End. Each variation produces the same outcome.

Given that nobody appears to have raised this in the Community Forums makes me worry that it may be something specific to my particular hardware set up.

Any help or suggestion would be greatly appreciated.


Just to follow up… this problem seems to have been specific to the particular OS (MacOSX El Capitan). On machines running HighSierra or Mojave, everything worked as expected. So, in our case, the issue has been resolved (indirectly).