open-ended string input not functioning

The problem I’m having is probably something I’m just overlooking, but I can’t seem to figure it out on my own, so I’d like to ask for help. I’ve built an experiment and several of the responses are open-ended string input. The first two such responses work fine, but after the third response, none of them work.

I’m attaching my experiment in hopes that someone can give me some insight about something I have overlooked. Just to be clear, I have tried deleting these events and adding them again, I have checked to make sure that each type of input I have established has the “only if an event designates” option selected, and I have specified a correct response for each type of input. I’d really appreciate it if anyone could tell me what I might be overlooking. Thanks!

P.S. If anyone tries to run my experiment to look at the problem, enter a 1 or 2 in the participant name.

Experiment.sl5 (27.7 KB)

One of our developers looked into your experiment and it seems like you may have stumbled into a bug that is present in the Windows version. They will be looking into it.

Meanwhile, try one of the following workarounds:

  • Remove the event “Demographics: Class". We’re not exactly sure why it helps, but by removing it, you will be able to proceed through the whole demographics section (with many string-input responses) without trouble.
  • If you have access to a Mac, try using SuperLab for Mac instead; the bug is not present in the Mac version.

More information…


Thank you for the information. I have tried taking out class, but I wanted to let you know that I’m now having the same problem later on in the experiment. It appears that I have the problem whenever I have an open-ended string input response after a mouse-click response. I hope this helps. Any more information would be greatly appreciated. Many thanks!

A developer was able to find the bug and fix it. The fix will be part of a SuperLab 5.0.4 coming out later this year.

Meanwhile, a workaround is for you to use SuperLab for Windows version 5.0.1, or any SuperLab for Mac 5.x version since the bug is Windows-specific.

Thank you

Thank you for the assistance. This has been an extremely helpful fix, and it enabled me to run my experiment normally. I truly appreciate all of the effort you have devoted to this issue.

The bug fix is now included in the SuperLab 5.0.4 update that we released last week. You can get the latest version from our SuperLab 5 Update page.