Movie trial won't end, text from next event showing up behind movie.

I’ve got an event with a movie stimulus type, and though input is set to “immediately after event is presented”, the next event doesn’t start. I’ve also tried setting the input to “only after a time limit” using 3 ms, and that doesn’t work either.

Second problem: the text for the event following the movie event is showing up behind the movie (see attached).

(Superlab 5.0 on a mac running OS10.9)

In the current version of SuperLab, it is not possible to overlay text on top of a running movie. If you want to show a text event and movie simultaneously, then they must be in two different locations on the screen - they cannot overlap.

The steps that you describe seem right thus far, but there has to be another setting that’s preventing the next event from starting. You did not attach an experiment. I’ll check it out when you upload it.

Re: first problem: Experiment package attached.

Re: second problem: I don’t want the text overlaid–it’s an error, not something I’m trying to achieve.

Thanks! (870 KB)

I looked at the experiment. A couple of quick questions:

One, do you want the subject to be able to answer as soon as the movie starts to play? or when the movie has finished playing?

And two, do you want the last frame of the movie to remain on the screen after it has finished playing? or to be erased?

  1. I want the next trial to start as soon as the movie has finished playing–no response is required for participant. Setting input to
  2. I want the next event to start.

I tried setting the stimulus presentation settings so it’s no longer looking for ppt input while the movie is playing. That fixes the issue, so the movie is now ending and the next event starting. But now the text from the previous event is showing up behind the movie while the movie plays.

I have attached a modified experiment. Note: I have ran only the block “NoInstruction”, so you still need to look at the other blocks. Some notes:

  • For the event “VideoInstruction”: in Settings > Presentation Options, I selected the option to “Erase stimulus” when event ends

  • For event VideoPromptNI: I moved the stimulus lower on the screen

Also, the block “NoInstruction” has randomization enabled, which means that instructions may or may not show up before the videos. The instructions portions should probably be part of a separate block so that you can keep randomizing the video presentations.

InstructedGesture rev B.sl5 (13.2 KB)