Issues w/4.0.6 on PPC Mac 10.5.2

I’ve been playing with 4.0.6 on my 17" 1GHz Powerbook (I notice that the voice key now claims to take subject responses from the SV1 accessory connector–I’ll be using that feature substantially, thank you). There are problems with crashing that I’ve seen in three places. First, with a completely blank, new experiment, select new block, and then click on the “+” sign to create a new conditional expression. The expression editor comes up, with the mysterious string “qqweqwe” in the “Subset:” window, and the beachball starts spinning; within a minute or so, Superlab crashes.

It is very similar with a new trial: on a new, blank experiment, select new trial, and then click on the + sign to create a new condition: beachball, eventual crash.

Also, on this machine, SL seems to be very uncomfortable with image stimulus lists that contain the same image path more than once. It detects this and issues a warning, but it lets you add it if you want. But later on, if you try to use it in an event, or if you try to edit it later, SL will crash. There appear to be some things you can do with this kind of list, but sooner or later, it will crash SL. Also, when there is a list with a single item repeated more than once, the earlier instances of the file path show up as blank lines in the Stim list editor.

As a comparison, I also tried the same three things on a Macbook Pro running Tiger, and everything worked fine. Unfortunately, that doesn’t distinguish between the processor type and the operating system level.

Greg Shenaut

FWIW, I tried on a Macbook Pro running Leopard, and didn’t get an error. So the problem may be specific to the PPC.


You are correct in this being PPC-specific. I got the crash to happen on my Mac Pro when launching SuperLab under Rosetta. Thanks. I’ll be looking into this.

This turned out to be a compiler optimization bug. I hate those. We did everything right, but the program still crashed. This is therefore fixed for the upcoming 4.0.7 release (expected to be the last of the 4.0.x line… but so was 4.0.6).

For future reference, on your Intel Macs, you can launch Universal Binaries as PowerPC by selecting “Open using Rosetta” in the Finder Get Info window. Under Leopard, there’s also a check box to choose to launch in 32-bit mode.

Thanks, Hank. I hate compiler bugs too.

Your bug got mentioned in the release notes. :wink: