I’m building an experiment based on reaction time, and I would like to bring a feedback to the participants.

Here is my problem:
I’ve got a sound file, which lasts about 15s. I made this event end immediatly after it is presented, in order to put a visual stimulus telling the participant which key he must press when he detects the sound. then I put a feedback on this visual stimulus. As soon as the participant presses the key, the feedback appears, telling him that his answer has been recorded. but I don’t want to end the sound and skip to the next one too early. I want it to finish playing.

If I turn on the option “wait for sound to finish playing”, superlab starts looking for the participant response after the end of the sound: I can’t collect the reaction time.

I can’t give the feedback a time limit, as I have no idea of when the participant will press the key (will it be at the beginning, in the middle or at the end of the sound file?) I don’t want the participant to press a key to end the feedback. I tried to give a time limit to the trial, but it doesn’t work. All the events in the trial (and also the feedback) must end before the interval time elapses.

I tried to make the visual stimulus come first and end it immediately after it is presented. Then the sound file comes, and the feedback is necessarily put on this soundfile. When the participant hears the sound and presses the key, i’v got the same problem than before. I don’t know when the feedback must end. Moreover the feedback takes the lead and quickly the sound can’t be heard any more, evn if the feedback lasts until the end of the sound.

Is there any possibility to put a feedback without asking the participant to press a key again and without skipping to the next sound too early?


Have you tried using the setting “Wait for audio to end before ending trial”? Also, please make sure you are using the latest version of SuperLab, SuperLab 4.5.3.

Well, in fact the software version is Superlab 4.0.

Where is the setting you are talking about? Does it exist for this version?

I recommend that you first upgrade to SuperLab 4.5.3. The setting is within SuperLab 4.0 and SuperLab 4.5.3. You can find it within the Event Editor, under the Stimulus tab when you choose the Audio event type.