Error message on non-administrator account

Hi. My research assistants have started to get an error message when starting Superlab 4.5. See the attached screen shot of the error message. This error message just started happening. The program worked fine on non-administrator accounts before. When I run Superlab from my administrator account this does not happen. The only thing that I am aware of that has changed is that I updated the software and drivers for a National Instruments card. Does anyone know how to remedy this issue? Simply dismissing the error message does not seem to work as it keeps popping up and keeps Superlab from running. Another thing to note is that the path that is contained in the error message doesn’t even exist on this computer. Any help would be greatly appreciated.

superlab 4_5 error message.JPG

additional info

I forgot to include the fact that the computer is running Windows 7.

Thank you so much for attaching a screenshot. That always makes things crystal clear. I love screenshots!

I am so sorry that this error pop-up is causing trouble. Now that you have reported the problem I will make sure this does not occur in future updates of SuperLab.

In the meantime, I believe I can show you how to fix this using entirely Windows-based file permission settings without needing to update or alter SuperLab in any way.

The first thing to note is that the file path does exist, but Windows has kept it hidden. The ProgramData folder is hidden by default, but I can assure you that it does exist. You won’t even have to unhide it – I can show you an even easier way to simply open the folder even though it is still hidden.

I made a very short “screen-sharing” video (less than 1 minute long) that will show you how to find this file and make it accessible to the accounts of the research assistants.

You should log in as the administrator before following the steps in this video.

Also, once you are able to see where this cedrus_license_error_log.txt file is, then you might feel tempted to just delete it. That may or may not work, but I recommend just granting permissions on the file instead of deleting it. Deleting it might work, but only if the next person to launch SuperLab is a non-admin user, and if all the non-admin users always use the same non-admin account.

Here is the video:

Please let me know how things turn out after following the video.

Thank you for reporting this problem. I am eager to fix it in SuperLab itself, and I am optimistic that the file-permission workaround will eliminate the problem in the meantime.

It just occurred to me that it would be most prudent to grant permissions on the Licenses folder as well as the error file inside.

Here is a follow-up showing essentially the same permissions steps as before, only this time applied to the folder:

By granting the assistants access to the folder, then even if the error pop-up comes back and starts causing a nuisance for the research assistants, then at least they should be able to go remove the cedrus_license_error_log.txt file on their own and then re-launch SuperLab without any trouble.

Fixed in SuperLab 5

I’d note that this issue was resolved in SuperLab 5 back in 2013.