Difficulty with using Response Pad with Demo Tasks

Hello all,
I’m having trouble changing the inputs over from the keyboard to the response pad for the example by VanOrden from the downloads. The pad itself is all hooked up and accepts inputs, but they come up as incorrect (E) under the “Correct Response” column in the data file. However, if I press “Z” or “/” it will come up correct ©. I’ve tried changing the accepted inputs, but it still comes up “E”. I’m new to SuperLab, so maybe I’m missing something, but any help is greatly appreciated as I am supposed to be converting all of the examples from keyboard inputs to response pad inputs.

I think the problem might be a setting under the Correct Response tab in the Event Editor. Can you post your experiment so I can take a look?

Sure, it’s just one of the ones you can download from the Cedrus site, so I’m not entirely sure where the problem is stemming from. Any help is greatly appreciated. The file should be attached.

VanOrden.sl4 (80.9 KB)

I apologize, but can you post as an Experiment Package? This is found under the File menu within SuperLab. I cannot run your experiment because the files were not included.

Sorry for the delay. I cannot attach all the files because they are too numerous. However, if you go to this link (http://community.cedrus.com/showthread.php?t=920) the two files on the bottom are the experiment with the files. If you have them and place my version of the experiment in the same folder, you can use the pictures from the original, they will be the same.

Not all the events have a correct response set. Also, the experiment is only set up to collect data from a few events. Under the Input tab in the Event Editor, Record and Save data is not selected for most of the events.

That makes sense, but why, when I look at the data, does it come up that each event does have a correct response? And how do I change the experiment so that it works with a response pad and not just the “z” and “/” keys? My main goal is to change this, and all the other experiments on this site, to work using the response pads rather than the key board. When I go into the experiment and add the response pads as possible input devices, it accepts the change, but in the data file it is not recorded.
I’m still rather lost…

P.S. A data file is attached for the experiment run on the key board to show how it will look.

SuperLab Data File.txt (8.17 KB)

It is coming up that each event has a correct response because the experiment is set up that way. If you go into the Event Editor, then the Correct Response tab, you will see on the right hand side that it says under …“the correct response is” None, any response is correct.

If you do not want to use the keyboard, then go to the Experiment menu and choose Participant Input. Here you will un-check the Keyboard-Single Keys and leave the RB-x30 Series Response Pad selected.

Also, please remember that you have to go through every event and check the Record and save data option under the Input tab in the Event Editor. If you don’t do this, only the “Mask” events will show up. In the data file you posted, I did not see any RB-730 responses, only responses using the keyboard. Please let me know if I am missing something in the data file.