Biopac student lab pro and triggering


My first question would have to be if Biopac student lab pro (BSL) is compatible with SuperLab 4.0.

Right now I am using the Biopac MP35 to record EMG responses. I am using a PCI-DIO24 I/O card from the computer running superlab to the MP35, which then connect to my recording computer via USB.

One of the options in BSL is being able to start recording due to a trigger. The options appears to be either trigger (which has its own port in the back of the unit), or D1-D8 (I assume standing for digital input). I’ve been trying use superlab’s Digital Output feature to sent the trigger to start the recording, but it has not been working at all.

According to BSL, the trigger needs 2 Volts to reach trigger level, and I don’t know how to set up superlab to do that. Let me know if any more information is needed to solve this issue.

Thanks in advance

Hi Jay,

I know that SuperLab is compatible with Biopac’s STP100 and MP35. I’m pretty sure that it’s also compatible with the student package, but better check with Biopac.

I would be great if you can post a follow up after you’ve contacted Biopac in order to let me and others know.



BSL follow-up

Dear community,

Well, I did manage to get Biopac on the phone. First off, I must say they have some of the best customer service I’ve experienced. Definitely recommend calling them if you have any issues with any of their products.

Quick note on how my computers were set up. I had my acquisition computer connected to the MP35 unit via USB, and my presentation computer connect to the MP35 via I/O connector.

Anyhow, what I discovered I was doing wrong was in the channel setup (under MP35 menu), I was checking the boxes next to the analog input channels, but did not turn on any of the digital input channels. The options are from 1-8, but I found out I only needed to use D1. Unless you want to record the trigger spikes, you only need to check the first box for the trigger to work.

After that was set up, I went to the trigger options (also under the MP35 menu). There I clicked on the pull down menu and selected D1 for my trigger. I just kept default positive edge selected.

Then on the presentation computer, I used Superlab’s digital output option (as a new event) and selected all the channels available (0-7 I believe). I kept the pulse options as the default.

Strangely, I still had the problem with Superlab not triggering the BSL. What I did was to start the software that came with the Measurement Computing PCI-DIO24 I/O card, called InstaCal. From that software I was able to run tests on the I/O card. I noticed that running the tests would cause the BSL to receive a pulse. After that, I closed InstaCal and went back to my Superlab program and it then was able to send pusles at BSL. My best guess would be that after installing the drivers for the I/O card, you need to run the software and run the tests to “activate” the connections.

Anyways, now Superlab and BSL are happily working in harmony, which is nice because now I don’t have to sit there and manually start/stop my EMG acquisition.

Hope this helps :slight_smile:


Thank you very much for the follow up. I really appreciate it.

Just to clarify: yes, InstaCal does need to be ran at least once in order to “install” the board. Sometimes it does it automatically after running, and sometimes the user has to select Add Board for this to happen (and the board number must be 0).