Windows Executable is not Responding

I’m having another issue with Superlab 4.0. I have a brand new computer running Windows Vista Service Pack 1 Updated, 3.0 GB RAM. While creating a new experiment, I will save and run the file but instead of running I get an error message that reads Windows Executable is not Responding. I then have to press CTRL+ALT+Delete to get to the Task Manager and stop Superlab. The file that I have created so far is only 9.5KB

What happens if you press the Esc key and wait a few seconds? Will SuperLab ask you to confirm whether you want to exit the experiment?

No the escape key will not work at all.

Also, I should have added that I have the latest version. After I get into the task manager, I see run (for superlab) and superlab as tasks, and after ending run, the exact error message is Superlab Pro 4.0 executable is not responding

Can you post the experiment?

Also, before running the experiment, can you verify the precise version of SuperLab that you are running? In SuperLab, select the “Help” menu and then “About SuperLab.” The window that opens should say which version of SuperLab: 4.0.something. Thanks.

I am running Version 4.0.7b Build 3488.

Between now and my last reply, the situation has changed somewhat…

  1. Sometimes when I press escape after the program I created stops responding the pop up screen pops up asking me if I want to cancel the experiment but more often than not
    the escape key does not work and I have to force it to quit with the Program manager (with the same error message displayed about the Executable displayed), or it quits on its own (with the same error message about the Executable displayed), and/or sends a crash report.

I think that I may have been having the same problem as was jo van herwegen on June 2008, because I am dealing with audio and simultaneously presented visual stimuli, where a might have had a non-visual event (Audio) using mouse input with automatic stimulus positions.

In any case, after implementing those changes I am still experiencing an excessive about of the freezing described above. I’ve attached my work in progress


Test 2.sl4 (9.54 KB)

Please post the entire experiment including any stimuli files being used. You can email it to me if you’d rather not post it publicly.

This is the entire experiment. When I download the file from my post it is complete with the stimuli. Do I also have to as separate files send the 3 jpg’s?

Oh I see I needed to use the create a stimulus package option. In any case, everything seems to be working okay now so…Thanks

Without observing the behavior myself, my first theory is that this is related to the ISI event since it explicitly does what Vista is misinterpreting as a crash. If this event was something other than an ISI (e.g. a blank text event that lasts 1000ms), then the “crash” issue may go away.