Installing 4.5 - side by side configuration error

I have tried installing superlab 4.5 on a PC running vista which already had 4.0.8 installed. Version 4.5 installed ok but when trying to run it you get the error message “the application has failed to start because it side-by-side configuration is incorrect. Please see the application event log for more detail”. What is causing this error? What is the fix?

Version 4.0.8 seems to still run ok. I’ve tried the obvious such as uninstalling and restarting the pc but I can’t get 4.5 to run.

Installing 4.5 - side by side configuration error

Thank you for posting the precise wording of the error message. That always helps.

I am perplexed as to why you are seeing this error. We have tested the installer on several Vista machines without encountering any problems. Also, many SuperLab users have already successfully installed 4.5 on Vista without trouble.

The error message that you are seeing is related to incompatibility problems with various versions of “Microsoft Visual C++” that can be present on a Windows system.

We first encountered these Visual C++ problems on Vista in 2008, but we were able to fix the problem then:

The changes we made to our installer back then (in 2008) should still be effective today.

Here are my first thoughts (and I will continue to research this and post again on Monday):

  1. Do you have access to another Vista machine that has never contained a prior SuperLab version? If so, please test on another Vista machine. (You don’t have to activate a SuperLab license – just test that it installs and launches in the free demo mode.) I would think that it isn’t likely that the presence of 4.0.8 is contributing to the problem, but it might be.

  2. How are you launching SuperLab 4.5 ? If you are using the Windows Start Menu, or a desktop icon, or opening SuperLab via double-clicking an experiment file, then please stop doing those things and try this: Go to “C:\Program Files\SuperLab 4.5” (or wherever you installed SuperLab 4.5) and double-click on “superlab.exe” directly.

  3. If 2 did not help (above), then try right-clicking the superlab.exe file and then do “Run as administrator”.

  4. If neither 2 nor 3 fixed it, then right-click superlab.exe and choose “Properties”. Go to the tab labeled “Compatibility”. Check the box next to “Run this program in compatibility mode”. Choose “Windows XP (Service Pack 3)” or “Windows XP (Service Pack 2)”

Hello again!

I just thought of something else. Since the Microsoft error pop-up does include the phrase “Please see the application event log for more detail”, I suppose I would be remiss if I did not ask you to examine the event log and let me know what information you can find there.

You need to launch the “Run” utility (by using the key combo WINDOWS_KEY + r, or via the Start Menu as shown in the link below).

Once you get the “Run” window shown, then type eventvwr to launch the Event Log Viewer.

In case my images do not show up automatically, then here are the URLs to the images:

Thanks for the replies. I’ve not made much progress here. This is what I’ve found out:

  1. Running superlab.exe directly still produces side-by-side error

  2. Running as administrator still produces side-by-side error

  3. Running with XP compatibility still produces side-by-side error

  4. eventvwr reveals the following error:
    Activation context generation failed for “C:\Program Files\SuperLab 4.5\SuperLab.exe”. Dependent Assembly Microsoft.VC80.CRT,processorArchitecture=“x86”,publicKeyToken=“1fc8b3b9a1e18e3b”,type=“win32”,version=“8.0.50727.4053” could not be found. Please use sxstrace.exe for detailed diagnosis.

  5. I’m not sure the problem is that visual c++ files are not installed as I’ve tried installing them directly as suggested in the post here:
    and you still get the same error

  6. Just so you know the pc I’m using is a sony vaio sz laptop running vista business and 4.0.8 runs fine on it.

  7. I’ve tried installing superlab 4.5 on a second pc - this one is a sony vaio fz laptop running vista home premium. This laptop has never had superlab on it. The install nearly completes and then the following error occurs:

Setup was unable to create the directory c:\ProgramData\Application Data\Cedrus
Error 3: The system cannot find the path specified

Retry goes nowhere and if you click ignore a few times the install completes. However, on running superlab you get the same side-by-side error. I suspect I didn’t get error above on the first laptop was because I already had an older version of superlab on it and that this older version had previously created the Cedrus folder.

Any ideas? Clearly there is something not right with the installation of superlab 4.5 related to vista.

Activation context generation failed. Dependent Assembly Microsoft.VC80.CRT

Hi Mark,

Thanks so much for your continued help in diagnosing this problem.

I am setting up a fresh install of Vista right this moment so that I can hopefully reproduce this problem and fix it.

I will post another update shortly.

Ultimately I will probably need to send you a link for a new installer. I apologize that our current installer is not working for you.

Vista SP1 or SP2? 32-bit or 64-bit?

Hi Mark,

If you get the chance, please confirm for me that your Vista machines are running at least up to “Service Pack 2” for Vista.

Also: is this 64-bit Vista or 32-bit Vista that you use?

You could also check whether they are running with “The Platform Update for Windows Vista”, but I do not think that would make too much difference.

Extra reference:

Windows Vista Service Pack 1 (SP1) released on February 4, 2008

Service Pack 2 for Windows Vista released to manufacturing on April 28, 2009

The Platform Update for Windows Vista was released on October 27, 2009. It includes major new components that shipped with Windows 7, as well as updated runtime libraries.

The Platform Update for Windows Vista (Oct 2009) consists of:


The screenshot shows a search for installed updates by doing “Start -> Control Panel -> Programs -> View installed updates”

Sxs intaller problem verified and a workaround is available

Hi Mark,

I reproduced the problem on a fresh “from scratch” Vista install today.

I apologize for your troubles. No need for you to run any further tests or investigations on your machines now.

You can fix the problem by downloading the following:

Please note that on this particular version of the visual c++ patch the date is “Date Published: 9/20/2010”.

There have been numerous different updates to the visual c++ libraries over the past few years.

We will have a repaired installer ready over the next few days.

In the meantime I hope you will find that the above link for “Microsoft Visual C++ 2005 Service Pack 1 Redistributable Package ATL Security Update” will solve the problem.


Thanks for confirming that the problem is with your installer.

When I download the file you recommend:

then this does fix the side by side error.

However, there is still the problem I mentioned earlier when you try to install superlab 4.5 on vista that has never had superlab (of any version) installed previously on it. Towards the end of the installation you get the error:

Setup was unable to create the directory c:\ProgramData\Application Data\Cedrus
Error 3: The system cannot find the path specified

If you click “ignore” 3 times then the installation completes (though obviously the Cedrus folder has not been created).

What is causing this problem and what is the fix?

Please ignore “unable to create directory”. To be fixed in next installer.

I have not succeeded in reproducing the “unable to create directory” error. I am working with a clean Vista install with no previous SuperLab software present. I can run the 4.5 installer without seeing this “unable to create directory” error.

However, the directory-related error can be ignored. The installer is trying to create a small text file named “SuperLab.ini” and store the file in a common directory.

The “SuperLab.ini” file is not essential to SuperLab. In fact, that part of the installer is only present in the installer for legacy reasons. I will go ahead and remove that portion of the install script while I am making a fresh installer that fixes the “side by side” Visual C++ problem.

Although I cannot reproduce your directory-creation error, I do have a hypothesis that at least partially explains what went wrong. (Again, though, the error is safe to ignore.)

The installer is supposed to look for “C:\Users\All Users”, and then append “Application Data” to the end of that.

If you navigate to “C:\Users\All Users” (using a command prompt window) and run “dir /a”, you can see that

C:\Users\All Users\Application Data

will actually just redirect to “C:\ProgramData”

When the installer runs without error, the folder and the ini file that are ultimately created are:


(You would never actually find anything at “c:\ProgramData\Application Data\Cedrus”)

Somehow, on your Vista machine (the one that displays this error), the installer is retrieving “c:\ProgramData” as the “ALL USERS” directory.

Sorry about this. Your contribution of these thorough problem descriptions is much appreciated!

Both Vista errors are now fixed

The SuperLab 4.5 installer that is currently available for download will now work error-free on Vista.

See here for the download:

Thanks for sorting this out. I can confirm that the problems with vista are now fixed.