how to limit stimulus presentation time but not response time


I use stimulus lists.
I need to limit the presentation time of my stimuli to 1000 ms, which I did with “input” in the “event editor”.
However, I want my subjects to have the time they need to answer after the stimulus has been presented. So, they will have a black screen during this time.
I can’t find out how do to this.

Thanks for your help,


You will need to follow your main event (the one with the 1000 ms time limit) with another event that erases the screen and waits for the input. This can be with an event of type Text.

I can’t do that because I have several stimulus lists in my trial with randomization.
My events are like that in my trial:

  • ISI
  • Stimulus list A (1000 ms)
  • Stimulus list B (1000 ms)

I have “randomize the events in this trial” "except for the first one. So, if i create one new event to erase the screen after each stimulus list, these new events will be randomized too.

From our experience, randomizing at the trial level is rarely what a user wants. Is there a specific reason? If you’re not 100% sure, try randomizing at the block level instead.

If that is not an option, then the trial level randomization also offers the option of omitting the last event from randomization.

The reason was that I use stimulus lists; so I wanted the events
in my stimulus lists to be randomized within each particular list, and also for the events of the first stimulus list to be randomized with those of the second list.
But I forgot that when superlab runs a stimulus list, it creates a trial for each event.
So your solution works and I will use the randomization at the block level.