Digital Output

I’m having a problem similar to the one posted about in February in this thread:

I’m running an ERP experiment using Superlab 4.0.5 and Neuroscan with a NI PCI-DIO-96 card.

I know that Superlab and Neuroscan are interfacing because when I use the “Test” function in the event editor, triggers are sent to Neuroscan with no problem.

However, when I run my experiment, triggers are not sent.

This is a very serious problem for everyone in my lab, as we’re not able to collect data. Please advise ASAP.

To clarify, the post in Feb. wasn’t resolved as far as I can tell.

Please help.

Anyone? :frowning:

The post in February was likely with SuperLab 4.0.1, and it was specific to Measurement Computing.

When using the “Test” function in the event editor, have you tried increasing the number of times the pulse should be repeated? Do all of those pulses go through? This is important because the ports may flicker on and off each time the test button is pushed as a result of the device being reset. Every time you preview an event, a mini-experiment is created and run–including pre-experiment setup and post-experiment cleanup. The setup could simulate the appearance of a pulse when there may not actually be one. National Instruments changed what they call the pins on the PCI-DIO-96 card between NI-DAQ and NI-DAQmx. Are you certain that your connections are correct? Sending a repeating pulse would be a fabulous method of verifying.

I verified that SuperLab 4.0.5 is working correctly with my USB-6501. I left the pulse properties at the default, and it appears that all of my pulses were output correctly.

Hi Hank,

Thanks so much for the reply. In a roundabout way it helped me fix my experiment.

Here’s what was happening:

Instead of using ‘generate a pulse,’ I was doing ‘raise lines,’ ‘lower remaining.’ This is because when I was testing ‘generate a pulse,’ it was only sending '255, which confused me. When I tried to send multiple pulses like you suggested, It started doing '255 '7 '7.

I changed everything back to ‘generate a pulse,’ and it’s sending my triggers correctly. I had multiple people look at it and no one could figure that out. We were all thrown off by the '255.

Thanks again,