Announcement

Collapse
No announcement yet.

Audio marker timing with Stimtracker quad and Biopac

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Audio marker timing with Stimtracker quad and Biopac

    Hi. I have compared the Stimtracker audio marker to the Biopac HLT100c marker on a MP150 system in AcqKnowledge 4.0 and have found a consistent 1 ms delay from between the two (with the HLT occurring first). See the first picture. I’m unsure which is more accurate. Any thoughts?

    I also tried using a DC square wave created per Biopac’s AS-214 document on the right channel with the audio signal on the left going directly to the Stimtracker and I find the signal onsets having a discrepancy of 18ms. See second picture. I’m unsure which digital channel the Stimtracker is sending the left and right signal to so I don’t know which signal is delayed. Any thoughts on what might be causing this?
    I’ve included the audio file.

    Thanks!
    -Joe
    Attached Files

  • #2
    A colleague tested the audio file that you posted. m-pod pin goes high 500µs after the start of the sound with the default threshold setting of 50. If you reduce the threshold setting to 10, the delay from the start of the audio to m-pod output is reduced to <100µs.

    The 18ms is the length of the DC pulse being fed into the audio input. The audio input is meant for AC signals so it only sees transitions of a DC signal. Because StimTracker is looking for the envelope of the audio, it sees the falling edge of the input pulse.

    If you want to use an audio channel as a marker, I suggest using a tone (e.g. 1kHz) rather than a DC pulse. If you wish to use a DC pulse, you can try feeding it into one of the light sensor inputs.

    Comment


    • #3
      Thanks! This is helpful.

      Comment

      Working...
      X