Announcement

Collapse
No announcement yet.

Presenting stimuli from different lists, with no repetition

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Presenting stimuli from different lists, with no repetition

    Hello everyone,

    In my experiment, I want to present each block only once, each trial in each block only once, and the events that use stimuli lists only once as well. I want events to be presented in a specific order (no randomization).

    Under "trials", I have checked ":
    Present trial only if the following criteria are met: number of times this trial has been presented = 0

    Under "blocks", I have tired to check "No looping, present trials only once" but for some reason anytime I go back to this rubric, "Present trials in this block 2 times" is checked".

    I see that in the sample experiments for Superlab 4, there is one called "Choosing Pictures From Different Lists, With No Repetition".
    Would you recommend I follow the procedure adopted in that experiment, or is there another way with Superlab 5?

    Thank you!

  • #2
    You do not need to set any options to present each block, trial, and event once. This should be the default behavior. Try setting your desired option in the Looping tab, press OK, and then immediately do so again.

    Comment


    • #3
      Resolved

      Thanks, Arman!
      I had to try several times, but it's now working!

      Comment


      • #4
        Well... no, running the experiment shows it did not work

        Hello!

        It's all in the title. I thought it would work because at some point I was able to keep the "no looping, present trials only once" function on, which is not the case anymore.
        In fact, when I try to run the experiment, trials in the same one bloc keep coming back and it does not move to trials in another block.

        Is there anything else I can try?

        Thank you!

        Comment


        • #5
          It seems that anytime you navigate to the Looping tab, the second option is automatically selected the next time you open it.

          Try this. When you navigate to that tab, click Cancel. Then, open the block editor - which should now already be at the looping tab - make your changes, and press OK.

          Cancelling after navigating to the looping tab prevents the undesired changes from setting in, but also allows you to edit looping without the strange behavior the next time you open the block editor.

          If this still doesn't help, please post your experiment. If you are using media files, click File > Create an Experiment Package...

          Comment


          • #6
            Thank you, Arman,
            Your suggestions enabled me to edit looping, but that does not solve the problem.
            There must be some details I am not thinking about...

            I am attaching my experiment (in progress).

            Thank you!
            Attached Files

            Comment


            • #7
              Unfortunately, I am not able to download your attachment. Can you try posting it again?

              Comment


              • #8
                Looping Settings Change Without Being Selected

                "It seems that anytime you navigate to the Looping tab, the second option is automatically selected the next time you open it."

                I am having trouble with this as well. Looping turning itself on is a significant problem when one needs to present the trials in a block just once...



                I hope someone is taking a closer look at this glitch.

                Comment


                • #9
                  Here it is! I hope you can download it this time. Otherwise please let me know. Maybe we can use dropbox?
                  Attached Files

                  Comment


                  • #10
                    This weird auto-select Looping glitch is still present in SuperLab 5. It's preventing me from presenting a Block only once.

                    Comment


                    • #11
                      Ditto; I have been having this problem for quite a while. I do find that I can re-select the "No looping, present trials only once" option and then save it and it *usually* doesn't revert to the looping, but I echo what others have said. It's disconcerting to have SuperLab turn the looping on entirely on its own. Please fix this bug!

                      Comment

                      Working...
                      X