Announcement

Collapse
No announcement yet.

Experiment brings up Superlab window from desktop

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Experiment brings up Superlab window from desktop

    We are running an experiment in Superlab 4.5 but have run into a problem which has me baffled.

    The experiment is a reaction time test. It displays a red square onscreen for a random number of seconds then replaces it with a green square. When the green square appears the subject has to click a mouse button as fast as they can. (the experiment then sends a signal to the stimtracker to communicate with a powerlab unit).

    After a couple of trials Superlab for some reason displays the original Superlab editor window onscreen in front of the experiment. The reaction test keeps progressing in the background (and it responds to the mouse clicks) but the Superlab experiment editor window stays front & center in the screen. You can't interact with the editor as the experiment is still running.

    If we try to minimise or move the experiment editor offscreen prior to starting the experiment it will still reappear at the edge of the screen. It seems to happen at random in the experiment as the superlab editor reappeared at different trials when we tested & re-tested the experiment.

    Any help appreciated!

  • #2
    Are you on Windows or Mac? which version?

    Comment


    • #3
      Windows 7.

      Comment


      • #4
        This is likely related to the Windows 7 (and Vista) Aero feature. Please see this forum thread.

        Comment


        • #5
          I'm afraid that older thread didn't yield any solutions for us. The pcs were already running the basic Windows 7 desktop theme. I found a workaround by changing the participant response from a mouse click to pressing the spacebar key when the green square appears. The experiment was able to complete without the previous display issue.

          Comment


          • #6
            Thank you for posting the workaround you found.

            We’re thinking that perhaps all that is needed to eliminate the issue is to have “Keyboard Single Keys” option enabled. If this hypothesis is correct, then you don’t need to require your participants to press the space bar.

            Would you mind please trying it out on your end? i.e. go back to the original experiment that was exhibiting the misbehavior, and simply turn on / enable the “Keyboard Single Keys” option. Does the misbehavior go away then?

            Comment


            • #7
              Hello Hisham,
              does the "keyboard single keys" option not have to be enabled in the first place in order to accept the Spacebar as input?

              Comment


              • #8
                The “Keyboard Single Keys” does have to be enabled if you want to use the spacebar. What I am suggesting though is this: do enable “Keyboard Single Keys”, but do not actually use the spacebar, i.e. go back to using mouse input.

                What I’m trying to determine is if merely enabling “Keyboard Single Keys” gets rid of the problem.

                Also, do you have by any chance two experiment windows open?

                Comment


                • #9
                  Understood Hisham, I'll enable the keyboard single keys as input option and get back to you if it solves the problem. (there is only 1 experiment window open at a time).

                  Comment

                  Working...
                  X