Announcement

Collapse
No announcement yet.

Weird audio in Mac-->Windows

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Weird audio in Mac-->Windows

    I'm working on a Garner interference paradigm design using audio stimuli (spoken sentences). The experiment was developed in Superlab 4.5 on a Mac, and we were hoping to run participants on Superlab 4.5 on a Windows computer (well, dual boot). When we attempted to run the experiment on the Windows computer, the sound files were distorted -- every item or two would sound choppy. This has never happened on the Mac used to develop the computer.

    The experiment contains 3 main blocks, with 1 event per block, and 1 stimulus list (of 64 audio files) per event. Any ideas about why this might be happening?

    Thanks!

  • #2
    Can you post your experiment as an Experiment Package? This is found under the File menu within SuperLab.

    Comment


    • #3
      Here is the experiment package. Thanks in advance!
      Attached Files

      Comment


      • #4
        The option you used in your Audio events "Wait for audio to end before ending event" is causing the problem in the Windows version. Try using Wait for audio to finish playing. I did not hear the distortion when using this sound option.

        Comment


        • #5
          Thanks

          I'll try that, Monika. Thanks. Any idea about why this is the case? (I'm just wondering whether there's something I should know in general so as to prevent future Mac --> Windows problems.)

          Comment


          • #6
            Now I remember why that isn't going to work for this experiment: we need to record response times relative to the ONSET of the stimulus (i.e. subjects will respond before the stimulus is over), but we need for the entire stimulus to be played.

            Can you think of any other ways to deal with our audio problem?

            Thanks!

            Comment


            • #7
              Unfortunately, we were aware of the bug in the option "Wait to for audio to end before ending event" but your experiment is the first time where we see an experiment not work unless the sound must be played synchronously, i.e. with the option "Wait for audio to finish playing" turned on. I don't know if this is due to the fact that the experiment was created on the Mac first and then moved to Windows. Developers will be looking into this, but I do not have a time frame. Meanwhile, unfortunately my only suggestion is to run it on a Mac.

              Comment

              Working...
              X