Announcement

Collapse
No announcement yet.

Problems with string input

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Problems with string input

    I am creating an experiment in which both single-key and string responses are used (see 1st attached file). I have read others' posts on this topic, so I've made sure that both the single key and string responses are enabled only when correct, and that all of my events only allow correct responses.

    The problem I'm having is that the string response field does not appear when called for. I have tried adjusting some of the various options for presentation of the preceding stimuli to no avail. I also tried creating a simpler experiment (2nd attached file) in which only string responses are allowed. In this experiment, the response field appears if I check "Show sting input's response field...for all events," but then I run into another problem when I run the experiment. In this case, the response field shows after the first item and proceeds to the next item upon clicking "Next" or pressing "Enter," but on the second item, when I type in an answer and press "Enter," the experiment freezes. Again, I tried fiddling with several options, but I can't seem to get to the root of the problem. Any help would be greatly appreciated. Thanks!
    Attached Files

  • #2
    Thank you for posting your experiment. The issue was you had to define a correct response for each event in your experiment. Also, under the Input tab you need to select, After a correct response from the participant. The following link has more information on why this needs to be done in SuperLab. http://community.cedrus.com/showthre...=single+string

    Also, a revision of your experiment is attached.
    Attached Files

    Comment


    • #3
      Thanks for your response, and for the file. I went in and made a few tweaks, but I've run into one more small problem. Whereas you had the string input set as the correct response for all items, I'd like to set a single key as the correct response for all of the items in the Word_matching_block. When I went in and changed the correct response from Word_input (string) to Sham_key (single key) for all of the items in this block, this caused the script to freeze at the second item in the block. I tried both unchecking Word_input and checking Sham_key in the correct response tab, as well as creating totally new events with all of the same parameters except for this change, to no avail. I see from the other post that you referred me to that this behavior usually indicates a conflict in the input modality, but I cannot see how this is possible, given that I am substituting Sham_key for Word_input, and that both single key and string responses are enabled only if an event designates that modality as the correct response. I am attaching the revised file and stimuli. Thank you.
      Attached Files

      Comment


      • #4
        The reason for the freeze is due to only one file in your stimulus list being changed to accept a single-key input. When in the Correct response tab, within the Event Editor, each file that is shown on the left-hand side must be changed to the single-key response. I went through the events under the "Word Matching_block" and only the first file was changed. Please see the attached experiment.
        Attached Files

        Comment


        • #5
          Okay, I understand why there was a problem. The experiment ran exactly the way that I wanted it to. Thanks for your help!

          Comment


          • #6
            Problems with string input SuperLab 4.5

            I wrote the first version of a script that used both string and single key inputs this summer. At the time I was satisfied that the script was working, but that the string input function was accepting input a bit slowly. I recently upgraded to 4.5. Now the program hangs up when it reaches the string input event. Is there something new I should be doing for 4.5? I tried the script on another computer using the earlier version and it ran fine.

            Comment


            • #7
              Can you post or email me the experiment?

              Comment


              • #8
                string input + single key input

                I uploaded the set of files that worked in version 4.07. The experiment is not polished yet, but it worked on another computer that had just 4.07 on it. Both versions appear to be on the computer I used to test 4.5--I wondered if that was a problem.

                Thank you
                Attached Files

                Comment


                • #9
                  When you say lag, do you mean the experiment would not continue? I looked through your events and events, "Number1-Number10" did not have a correct response defined. Make sure to define these as "digits" being the correct response.

                  Comment


                  • #10
                    Sorry

                    Thank you--that sounds like the problem--strangely the script seemed to work for the previous versions. However, in the earlier version the number input seemed to work slowly and in 4.5 the program would not continue.

                    Comment

                    Working...
                    X