Announcement

Collapse
No announcement yet.

First mouse click in an event not being recorded

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • First mouse click in an event not being recorded

    This experiment is assessing pain experience during a cold pressor task. Every fifteen seconds, participants are asked to rate their pain on two dimensions (unpleasantness and intensity) using two visual analogue scales that pop up, one after another, on the screen. The response we are looking for is a left mouse click, and the data we are saving is the pixel position of said click for each scale.

    For some reason, everything is working perfectly except for when the second scale pops up (this is randomized, so it has to do with presentation timing and not the second event itself) the first mouse click is not recorded as a response, and you have to double click in order to record a response and end the event to move on to the next.

    The first mouse click is also not prompting the feedback, though the second does.

    We have tried everything we can think of, and put at least four different heads together with no satisfactory results. Can someone please save the day??
    Attached Files

  • #2
    It does appear that there is a bug affecting some particular combination of feedback events and mouse responses. The developers are looking into this. For now, there is a workaround:
    • Go to Participant Input, then Mouse or Touch Screen. Under the Options tab, choose both, Wait until the key is released and
      Immediately after it is pressed


    It is important to note that "Allow audio to continue playing" is only recommended when two audio clips need to overlap. For this experiment, please use the audio setting "Wait for audio to end before ending trial" to avoid any potential issues with too many audio files staying active.

    Comment


    • #3
      Thank you so much! We were at our wit's end with this.

      Comment


      • #4
        Thanks for posting the question (and reply). I've been struggling with this one too.

        Comment


        • #5
          This issue has been fixed in SuperLab 5.

          Comment

          Working...
          X