Announcement

Collapse
No announcement yet.

Codecs for video playback

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Codecs for video playback

    Apologies for posting two threads, but I am having another unrelated issue with video.

    In my experiment, I need to show participants a series of short videos, with one video per trial. However, I am unable to see a preview of the videos in the Stimulus tab, and the videos themselves do not play (SL crashes) when I attempt to run the experiment.

    I encoded the videos in .avi format using one of the DV codecs (DV2000, I believe it was called--or something like that), but I am unable to play them in either SuperLab or Windows Media Player. I have also tried downloading a video from the Internet (.avi, xvid codec) and creating a simple experiment with one block, trial type, and event using that video as a fixed stimulus, to no avail. (This video does not play on WMP either.) I am using SL v. 4.5 on Windows XP, and WMP is version 9.0 (am having issues updating it). I am unclear on whether SL uses WMP as its platform for video playback, so I am uncertain of whether the problem lies in SL or WMP. I could also re-encode the videos using a different codec, but it is important that the videos be as high-quality as possible (I chose the codec I did b/c it seemed like it produced the best quality output). I am using iMovie HD (2006) to encode the videos into .avi format, and have a relatively limited choice of codecs to use for that container.

    Any suggestions would be greatly appreciated.

  • #2
    The video must be able to play in Windows Media Player. This is a prerequisite to having it work in SuperLab.

    Comment

    Working...
    X