Thread Tools  
jcroot
Junior Member
 
Join Date: Oct 2014
jcroot is on a distinguished road Posts: 10
audio event durations, Posted November 10th, 2014 #1
I've written a prepulse inhibition paradigm that presents one of six audio files that vary in length but presenting them all through one event instance. I've noticed some odd behavior in the way superlab presents these. There are three durations - 70, 100, and 160ms. When I specify to present these within a 1000ms event, the 100 and 160ms stimuli get cut off. When I specify 1000ms event and turn on "keep playing audio and stop it when trial ends" they present normally.

I don't understand why this would be since a 1000ms event is longer than the longest stimulus, so this should be an adequate amount of time in which to present the 100 and 160ms stimuli. Ideally, I would be able to indicate to superlab to play each audio stimulus for the time it takes and then move on, instead of specifying an event duration. Wanted to make sure I understood any possible timing issues before I proceeded with this setup. I've attached both. Any help is appreciated. Thanks
Attached Files
File Type: zip auditory test fixed event duration.zip (21.1 KB, 10 views)
File Type: sl5 auditory test keep playing.sl5 (4.1 KB, 5 views)
Reply With Quote
jcroot
Junior Member
 
Join Date: Oct 2014
jcroot is on a distinguished road Posts: 10
Posted November 18th, 2014 #2
Hi,
Wondering if there is any further word on this question. Thanks.
Reply With Quote
Hisham
Founder
 
Join Date: Aug 2006
Location: San Pedro, CA
Hisham is on a distinguished road Posts: 1,188
Posted November 24th, 2014 #3
I’ve downloaded the two versions of the experiment and I honestly cannot tell if they are cutoff or not. The sounds are too short for my untrained ear to detect a cutoff. However, I would like to clarify something. When the setting Look for participant input while audio is playing is not checked, then the 1000msec time limit that you specified does not start until the sound has finished playing. In effect, total duration is 1000msec + sound duration.

Try the following combination:
  • In the Stimulus tab, the option Look for participant input while audio is playing is not checked
  • In the Input tab, the option to end Immediately after the event is presented is checked
This will get you what you want.
Reply With Quote
jcroot
Junior Member
 
Join Date: Oct 2014
jcroot is on a distinguished road Posts: 10
Posted November 25th, 2014 #4
Thanks Hisham,
I've uploaded two more scripts.

auditory test revision is set up as you recommend
auditory test revision 2 is set up in the way that seems to play correctly.

The difference in sound duration can be difficult to hear. I've ordered the play sequence of the stimulus list so that it will be easier. Each trial starts with either a 78 or 85db prepulse followed by a 115 db pulse. The stimulus onset asynchrony between prepulse and pulse will either be 30, 60, or 120. The difference should be audible between scripts but please let me know if not.

78db 30soa - cuts off during pulse
78db 60soa - cuts off before pulse
78db 120soa - cuts off before pulse
85db 30soa - cuts off during pulse
85db 60soa - cuts off before pulse
85db 120soa - cuts off before pulse

Thanks again.
Attached Files
File Type: zip auditory test revision.zip (21.1 KB, 5 views)
File Type: zip auditory test revision 2.zip (21.1 KB, 5 views)
Reply With Quote
Hisham
Founder
 
Join Date: Aug 2006
Location: San Pedro, CA
Hisham is on a distinguished road Posts: 1,188
Posted December 1st, 2014 #5
James, we looked in detail at the issue and can confirm that SuperLab for Windows (Mac version is fine) has an issue when playing sound files that are very short in duration. We’ll be looking into this.

There is a workaround, which is to use the Movie file type to play your audio files. When prompted to locate a file, make sure to select “All files” (not just “All supported files”). If that option doesn’t work, then the next step is to convert the audio file to .MP3 format and it will work.

Caveat: using the Movie event type consumes significantly more RAM in general.
Reply With Quote
jcroot
Junior Member
 
Join Date: Oct 2014
jcroot is on a distinguished road Posts: 10
Posted December 2nd, 2014 #6
OK. Thanks Hisham. I'll try that.
Reply With Quote
dmduriancik
Junior Member
 
Join Date: Jun 2016
dmduriancik is on a distinguished road Posts: 1
Loudness, Posted June 6th, 2016 #7
I am using the PPI files from biopac and setting up a PPI lab in SuperLab 4.5. Is there a way to confirm the dB of the sound? If a subject turned down the volume on the computer that would lower the dB of pulse and prepulse. Am I missing something? I am new to Superlab (and actually biopac as well) but learning quickly. Any information or help would be great. Thank you.
Reply With Quote
Hisham
Founder
 
Join Date: Aug 2006
Location: San Pedro, CA
Hisham is on a distinguished road Posts: 1,188
Posted August 4th, 2016 #8
Alas no, there is no way to confirm the dB of the sound.
Reply With Quote
Thread Tools
Posting Rules
Forum Jump:
© Copyright Cedrus Corporation, 1991-2014.
All times are GMT -7. The time now is 02:36 AM.