Thread Tools  
OlgaLazareva
Junior Member
 
Join Date: Nov 2013
OlgaLazareva is on a distinguished road Posts: 4
Problem with playing Quicktime movie, Posted February 27th, 2014 #1
I have an experiment in which I want to loop a Quicktime movie until the participant responds by pressing Z or X. I am running into two problems:

1) The movie does not loop -- it runs once and stops.

2) The movie does not close -- when I am trying to present text as a feedback, it is displayed behind the movie. There is no option to clear the screen as in case of picture files, so I am unsure how to remedy this.

Any help would be greatly appreciated. I am attaching the experiment file (the relevant block is Speed Train Slow-Z).
Attached Files
File Type: zip Exp6H Sp14.zip (311.9 KB, 4 views)
Reply With Quote
MonikaT
Senior Member
 
Join Date: Mar 2008
MonikaT is on a distinguished road Posts: 1,279
Posted March 4th, 2014 #2
In SuperLab the only way to start the movie over is to restart the trial. Another way to accomplish this is to edit the movie file, so that the clip itself contains the same sequence five times (or ten times) in a row. Then SuperLab can play the actual movie clip only one time.

Regarding the feedback issue, a movie will only disappear at a trial boundary. It can persist longer than a trial boundary if certain settings are used, but the soonest the movie will clear off the screen is at the end of a trial. You may want to delete the feedback under the Event Editor, and instead create a Rule, under the Trial Editor. The Rule then will present your feedback text.
Reply With Quote
OlgaLazareva
Junior Member
 
Join Date: Nov 2013
OlgaLazareva is on a distinguished road Posts: 4
Posted March 6th, 2014 #3
Thank you! This solved the problem of the movie sticking on the screen.
Reply With Quote
Thread Tools
Posting Rules
Forum Jump:
Copyright Cedrus Corporation, 1991-2014.
All times are GMT -7. The time now is 02:24 AM.