Thread Tools  
lincoln
Junior Member
 
Join Date: Apr 2014
lincoln is on a distinguished road Posts: 6
Responding Causes Delay in Experiment, Posted June 11th, 2014 #1
Hello,

I've created an experiment where participants are presented with a cue, which is paired with a thermal stimulus delivered from an external stimulator. After my participants receive the thermal stimulus they are prompted to answer a series of questions relating to how they experienced the thermal stimulation.

When my participants do not respond, the timing between everything is perfect. However, when they respond, there is a delay of about half a second before the next event in my experiment, which then increases the longer the experiment runs.

I understand that there will be a delay as SuperLab records and saves the responses of my participants, but shouldn't this delay be consistent throughout the experiment? Is there an easy way to fix the timing of my events?

Any and all advice/assistance would be greatly appreciated.
Reply With Quote
MonikaT
Senior Member
 
Join Date: Mar 2008
MonikaT is on a distinguished road Posts: 1,279
Posted June 12th, 2014 #2
It would be helpful if I could look at the settings. Can you post your experiment as an Experiment Package? This is found under the File menu within SuperLab. Also, what is the "external stimulator" you are using with SuperLab?
Reply With Quote
lincoln
Junior Member
 
Join Date: Apr 2014
lincoln is on a distinguished road Posts: 6
Posted June 17th, 2014 #3
Hi Monika,

Apologies for the delay in responding to your post. I have attached the experiment package to this reply. We are using a Medoc Pathway system as our external stimulator.

Please do not hesitate if you require further information.

Cheers,
Lincoln
Attached Files
File Type: zip Pain Anxiety Pilot.zip (222.8 KB, 7 views)
Reply With Quote
MonikaT
Senior Member
 
Join Date: Mar 2008
MonikaT is on a distinguished road Posts: 1,279
Posted June 20th, 2014 #4
On the events "Rating 1, 2, and 3" they are all providing a feedback of a low volume beep. The beep is 400 ms long, could this be causing the delay?
Reply With Quote
lincoln
Junior Member
 
Join Date: Apr 2014
lincoln is on a distinguished road Posts: 6
Posted June 22nd, 2014 #5
I have trialled the experiment with the "wait for sound file to finish playing" box in the event editor unchecked, and if I respond to the prompted ratings following the delivery of the stimulus there are still delays (even if SuperLab is instructed not to save the data before the experiment runs).
Reply With Quote
MonikaT
Senior Member
 
Join Date: Mar 2008
MonikaT is on a distinguished road Posts: 1,279
Posted June 27th, 2014 #6
I ran the experiment and could not duplicate the issue. Please call us at (800) 233-7871 at your earliest convenience so we can troubleshoot over the phone.
Reply With Quote
lincoln
Junior Member
 
Join Date: Apr 2014
lincoln is on a distinguished road Posts: 6
Posted June 29th, 2014 #7
Hi Monkia,

Thanks for your assistance, but phone troubleshooting may be difficult as I am located in Australia.

After discussions with other users, removing the feedback beep appears to resolve the issue.

Again, thank you for your assistance.
Reply With Quote
Tags
delay, participant response
Thread Tools
Posting Rules
Forum Jump:
Copyright Cedrus Corporation, 1991-2014.
All times are GMT -7. The time now is 02:04 AM.