Reply
Page 1 of 2:  1  2  
Thread Tools  
christoph
Junior Member
 
Join Date: Jun 2009
christoph is on a distinguished road Posts: 3
SV-1 voice key and eprime, Posted June 10th, 2009 #1
Hi,

our SV-1 voice keys are not working with eprime. Checking the firmware version on the voice keys with Xidon revealed that the are running version 1.1. This version is known not to work with eprime.

Does anyone know where I can download the current version 1.3 of the SV-1 firmware?

Thank you!
Reply With Quote
Hisham
Founder
 
Join Date: Aug 2006
Location: San Pedro, CA
Hisham is on a distinguished road Posts: 1,203
Posted June 12th, 2009 #2
Christoph, I can confirm that it's a bug in SV-1's firmware. I have opened a report in our case tracking system and we should have a bug fix available soon.
Reply With Quote
christoph
Junior Member
 
Join Date: Jun 2009
christoph is on a distinguished road Posts: 3
Posted June 16th, 2009 #3
Hisham, I am glad to hear that you finally could replicate our problems. When do you reckon will the fix be available? I am asking because one of our researchers wants to start testing at the beginning of July. If the bugfix takes longer I need to find her an interim solution. I suppose we can update the voice keys ourselves (the are 2G ones)?
Reply With Quote
Hisham
Founder
 
Join Date: Aug 2006
Location: San Pedro, CA
Hisham is on a distinguished road Posts: 1,203
Posted June 17th, 2009 #4
I've attached the new version of the firmware. You'll need the Xidon program; SV-1 must be in XID mode. I look forward to your feedback. The new firmware sends 0x40 when voice key is detected.
Last edited by Hisham; June 23rd, 2009 at 04:23 PM.. Reason: removed attachment
Reply With Quote
christoph
Junior Member
 
Join Date: Jun 2009
christoph is on a distinguished road Posts: 3
Posted June 18th, 2009 #5
Hi! I now installed the new firmware on our voice keys and I can confirm that they are now sending 0x40 when the voice key is triggered in PST mode. I can also successfully tried to use them in eprime. That is great! Thanks a lot for this fix!

However, I noticed one minor issue: PST counts bits from 1 and not from 0. So, the PST SR Box is sending 0x20 and not 0x40 when the voice key is triggered. 0x40 is used for the screen refresh detector of the SR Box. In order to provide full compatibility with the SR Box it might be advisable to send 0x20 instead of 0x40 as well.
Reply With Quote
Hisham
Founder
 
Join Date: Aug 2006
Location: San Pedro, CA
Hisham is on a distinguished road Posts: 1,203
Posted June 18th, 2009 #6
You are right. I was off by one bit. Our RB Series response pads already send 0x20 to emulate a voice key when a key is pressed. I'll get back to you with an update soon.
Reply With Quote
Hisham
Founder
 
Join Date: Aug 2006
Location: San Pedro, CA
Hisham is on a distinguished road Posts: 1,203
SV-1 Firmware v1.4, Posted June 23rd, 2009 #7
Here's version 1.4 attached that sends a 0x20 -- as it should.
Attached Files
File Type: zip SV1_1B14BL.HEX.zip (7.9 KB, 23 views)
Reply With Quote
dbiun
Junior Member
 
Join Date: Sep 2009
dbiun is on a distinguished road Posts: 2
Posted September 2nd, 2009 #8
So what do we do if Xidon can't find the voice key?
Reply With Quote
Hisham
Founder
 
Join Date: Aug 2006
Location: San Pedro, CA
Hisham is on a distinguished road Posts: 1,203
Posted September 2nd, 2009 #9
if you have been using SV-1 with E-Prime, Xidon isn't smart enough to convert SV-1 from E-Prime mode back to XID mode, but SuperLab 4.0 is. You can download the 30-day trial and use it to convert SV-1 back to XID mode.

Note: when in E-Prime mode, SV-1 emulates the PST Serial Response Box. In doing so, it sends 800 or 1600 bytes per second to the computer, making it difficult for the computer to communicate with SV-1. You may need to try several times before SuperLab 4.0 tells you that it found an SV-1.
Reply With Quote
dbiun
Junior Member
 
Join Date: Sep 2009
dbiun is on a distinguished road Posts: 2
Posted September 2nd, 2009 #10
Xidon starts up, and when it does the autocheck I get an error message:

Debug Error
in Xidon.exe

Run-Time Check Failure 2 - Stack around the variable CBUFF was corrupted

IF I press ignore, then it comes up with a prompt that says
Xidon detected an XID device, but it is either unsupported by this version of Xidon or the firmware is out of date.
Reply With Quote
Reply « Previous Thread - General - Next Thread »
Page 1 of 2:  1  2  
Tags
eprime, sv-1
Thread Tools
Posting Rules
Forum Jump:
Copyright Cedrus Corporation, 1991-2014.
All times are GMT -7. The time now is 03:48 AM.