Thread Tools  
LDGG
Junior Member
 
Join Date: Feb 2017
LDGG is on a distinguished road Posts: 18
Hello everyone,

In my experiment, I want to present each block only once, each trial in each block only once, and the events that use stimuli lists only once as well. I want events to be presented in a specific order (no randomization).

Under "trials", I have checked ":
Present trial only if the following criteria are met: number of times this trial has been presented = 0

Under "blocks", I have tired to check "No looping, present trials only once" but for some reason anytime I go back to this rubric, "Present trials in this block 2 times" is checked".

I see that in the sample experiments for Superlab 4, there is one called "Choosing Pictures From Different Lists, With No Repetition".
Would you recommend I follow the procedure adopted in that experiment, or is there another way with Superlab 5?

Thank you!
Reply With Quote
Arman
Support
 
Join Date: Jun 2016
Arman is on a distinguished road Posts: 148
Posted February 20th, 2017 #2
You do not need to set any options to present each block, trial, and event once. This should be the default behavior. Try setting your desired option in the Looping tab, press OK, and then immediately do so again.
Reply With Quote
LDGG
Junior Member
 
Join Date: Feb 2017
LDGG is on a distinguished road Posts: 18
Resolved, Posted February 23rd, 2017 #3
Thanks, Arman!
I had to try several times, but it's now working!
Reply With Quote
LDGG
Junior Member
 
Join Date: Feb 2017
LDGG is on a distinguished road Posts: 18
Hello!

It's all in the title. I thought it would work because at some point I was able to keep the "no looping, present trials only once" function on, which is not the case anymore.
In fact, when I try to run the experiment, trials in the same one bloc keep coming back and it does not move to trials in another block.

Is there anything else I can try?

Thank you!
Reply With Quote
Arman
Support
 
Join Date: Jun 2016
Arman is on a distinguished road Posts: 148
Posted February 24th, 2017 #5
It seems that anytime you navigate to the Looping tab, the second option is automatically selected the next time you open it.

Try this. When you navigate to that tab, click Cancel. Then, open the block editor - which should now already be at the looping tab - make your changes, and press OK.

Cancelling after navigating to the looping tab prevents the undesired changes from setting in, but also allows you to edit looping without the strange behavior the next time you open the block editor.

If this still doesn't help, please post your experiment. If you are using media files, click File > Create an Experiment Package...
Reply With Quote
LDGG
Junior Member
 
Join Date: Feb 2017
LDGG is on a distinguished road Posts: 18
Posted February 24th, 2017 #6
Thank you, Arman,
Your suggestions enabled me to edit looping, but that does not solve the problem.
There must be some details I am not thinking about...

I am attaching my experiment (in progress).

Thank you!
Attached Files
File Type: tgz IF PI SI Experiment.tgz (85.12 MB, 8 views)
Reply With Quote
Arman
Support
 
Join Date: Jun 2016
Arman is on a distinguished road Posts: 148
Posted February 27th, 2017 #7
Unfortunately, I am not able to download your attachment. Can you try posting it again?
Reply With Quote
Bryan
Junior Member
 
Join Date: Nov 2009
Bryan is on a distinguished road Posts: 1
Looping Settings Change Without Being Selected, Posted February 27th, 2017 #8
"It seems that anytime you navigate to the Looping tab, the second option is automatically selected the next time you open it."

I am having trouble with this as well. Looping turning itself on is a significant problem when one needs to present the trials in a block just once...



I hope someone is taking a closer look at this glitch.
Reply With Quote
LDGG
Junior Member
 
Join Date: Feb 2017
LDGG is on a distinguished road Posts: 18
Posted February 28th, 2017 #9
Here it is! I hope you can download it this time. Otherwise please let me know. Maybe we can use dropbox?
Attached Files
File Type: sl5 IF PI SI Experiment.sl5 (202.1 KB, 1 views)
File Type: tgz NEW IF PI SI Experiment.tgz (85.12 MB, 1 views)
Reply With Quote
Thread Tools
Posting Rules
Forum Jump:
Copyright Cedrus Corporation, 1991-2014.
All times are GMT -7. The time now is 09:39 AM.