Thread Tools  
evan.chan
Junior Member
 
Join Date: Feb 2012
evan.chan is on a distinguished road Posts: 2
Hi,

The response pad was shipped prior to September 2010. It used to be able to work with the previous two computers. However when I tried to connect it to a new computer this time, I encountered this issue.

I followed http://www.cedrus.com/support/rb_ser...1059_mprog.htm. I deleted the existing USB driver (if any), and when it came to the step where the "Found New Hardware Wizard" windows was supposed to pop out, it never showed up. The Device Manager showed a new USB Serial Port (COM4) under the Ports (COM & LPT), but I did not see the Other Devices.

I also tried going ahead to go through the subsequent steps described in,

http://www.cedrus.com/support/rb_ser...1059_mprog.htm
http://www.cedrus.com/support/rb_ser...g_firmware.htm

The response pad was able to be detected by SuperLab using the Auto Detect function (with all switches on the response pad down). However, when the E-Prime was run (with switch 1 up) it showed the following error in spite of the fact that the Baud Rate and Port settings were correct,

Run-time Error (Line 606) 10051: An error occurred while attempting to open the device

Device Name: SRBOX
Error: 0x00004a46
Message: 'Unable to open the SRBOX: 0x00000103

The SRBox Device Driver may not be installed
For information on 64-bit support, please see http://www.pstnet.com/e-prime/suppor...p?TopicID=2581'
Reply With Quote
MonikaT
Administrator
 
Join Date: Mar 2008
MonikaT is on a distinguished road Posts: 1,280
Posted February 27th, 2012 #2
If you go to the link below and scroll to the bottom of the page, it describes the exact error message under Troubleshooting.

http://www.cedrus.com/support/rb_ser...047_eprime.htm
Reply With Quote
evan.chan
Junior Member
 
Join Date: Feb 2012
evan.chan is on a distinguished road Posts: 2
Posted February 27th, 2012 #3
Quote:
Originally Posted by MonikaT View Post
If you go to the link below and scroll to the bottom of the page, it describes the exact error message under Troubleshooting.

http://www.cedrus.com/support/rb_ser...047_eprime.htm
Hi Monika,

I did read the link you provided before I posted my questions. Unfortunately, it did not seem to resolve my problem.

I guess my problem was I was not able to install the driver. As I posted, the "Found New Hardware Wizard" never showed up after I plugged in the response pad and thus I did not have the chance to install the "Cedrus CDM 2.02.04" driver.

The Device Manager did show a new USB Serial Port (COM4) under the Ports (COM & LPT) (NO OTHER DEVICES), as well as Superlab can detect the response pad, but it did not seem to be sufficient to let the response pad work properly with E-Prime. I am confused what was happening behind the scene.

Could you please offer any further advice?
Reply With Quote
MonikaT
Administrator
 
Join Date: Mar 2008
MonikaT is on a distinguished road Posts: 1,280
Posted February 28th, 2012 #4
If SuperLab is able to "Auto Detect" the presence of the response pad this means that the USB driver is installed and working correctly. The problem seems to be E-Prime specific.
Reply With Quote
Thread Tools
Posting Rules
Forum Jump:
Copyright Cedrus Corporation, 1991-2014.
All times are GMT -7. The time now is 10:25 AM.