Thread: RB-530 and E-Prime: detection trouble View Single Post
Fabrizio
Junior Member
 
Join Date: Feb 2007
Fabrizio is on a distinguished road Posts: 5
RB-530 and E-Prime: detection trouble, Posted March 5th, 2007 #1
Hi,

We've recently purchased a Cedrus RB-530 response pad, claimed to be compatible with E-Prime through the SRBox 200A emulation. I've followed all the steps from the website in order to make it work with E-Prime. The pad works perfectly with Xidon in default mode (all pins down). The driver were of course installed properly. I upgraded the firmware to RBX30_c18.hex - file which was included in the downloadable Xidon of the support site (it was c18, not c14c as the site requested, but I thought it would be a finer upgrade). I then tested the 19200 and 9600 baud modes with E-Prime, using the SRBox default script which comes included with E-Prime 1.1.

It works fine in some PCs, but does not work at all in others. The pad is detected always with Xidon with the pins down, but not detected by some PCs in the 19200 mode. The message thrown by E-Prime is this:

Run-time Error (Line 462)
10051: An error occurred while attempting to open the device
Error: 0x00004a49
Message: 'Unable to open the SRBOX: 0x00000005
The SRBox Device Driver may not be installed'

And in 9600 mode, it states that the baud value is not correct/valid. So, basically, I can only work in some PCs, and never in 9600 mode. What is happening with the pad?

Cheers,

Fabrizio Ferri Benedetti
University of Valencia
Reply With Quote